aboutsummaryrefslogtreecommitdiff
path: root/lightboard/debian/rules
diff options
context:
space:
mode:
authorCyrille Henry <nusmuk@users.sourceforge.net>2010-11-11 13:48:43 +0000
committerCyrille Henry <nusmuk@users.sourceforge.net>2010-11-11 13:48:43 +0000
commitb302c1181513885303dc66c31b41db4c7d132f0a (patch)
tree3570d4003aecc452f9a5f2b3c285678ed9f463df /lightboard/debian/rules
parent9da11e77c190e23219bc2f8477051218974c1cf9 (diff)
lightboard can't fit in library template because it's more an application than
a library. so this is mostly useless. svn path=/trunk/externals/nusmuk/; revision=14413
Diffstat (limited to 'lightboard/debian/rules')
-rwxr-xr-xlightboard/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/lightboard/debian/rules b/lightboard/debian/rules
new file mode 100755
index 0000000..4fda13b
--- /dev/null
+++ b/lightboard/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = lightboard
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars