aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-04-12 22:26:38 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-04-12 22:26:38 +0000
commit48d170d5d50bb84a96d249f17e2048c48270ea97 (patch)
tree6f4ad76ffb0031ca29e185bf8112b248f6c8402f /debian/rules
parent40341076a954c0f54449c06a82034c6e267c57d5 (diff)
consolidated 'pddp' lib stuff into a single place to make a libdir, ease Debian packaging, and remove the pddpserver
svn path=/trunk/externals/pddp/; revision=13424
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0c273a4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = template
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+