aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 31aca5e..ac20560 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ AC_HEADER_STDC
dnl TAG CVS WHEN RELEASE VERSION CHANGES !!!
-PDP_VERSION=0.12.4
+PDP_VERSION=0.12.5-darcs
AC_SUBST(PDP_VERSION)
AC_ARG_ENABLE(mmx,
@@ -42,10 +42,11 @@ AC_ARG_ENABLE(debug,
[ --enable-debug enable debugging support (no)], , enable_debug=no)
-PWD=`pwd`
-PDP_CFLAGS="-DPD -Wall -W -Wstrict-prototypes -Wno-unused -Wno-parentheses -Wno-switch -I$(PWD)/../../pd/src"
+# long double? -Wno-long-double
+PDP_CFLAGS="-DPD -Wall -W -Wstrict-prototypes -Wno-unused -Wno-parentheses -Wno-switch -fPIC"
dnl -Werror -Wshadow
+dnl the -Wshadow option is way too strict.. gl headers won't compile
@@ -53,7 +54,7 @@ dnl setup debugging
if test $enable_debug == yes
then
AC_DEFINE(PDP_DEBUG, 1, "enable debugging support")
- PDP_CFLAGS="$PDP_CFLAGS -g -Werror -Wshadow"
+ PDP_CFLAGS="$PDP_CFLAGS -g -Werror"
else
AC_DEFINE(PDP_DEBUG, 0, "disable debugging support")
PDP_CFLAGS="$PDP_CFLAGS -O2 -funroll-loops -fomit-frame-pointer -ffast-math"
@@ -75,6 +76,7 @@ fi
dnl try to locate the pd header in case the setup is nonstandard
dnl check in $prefix/pd/src then ../pd/src
dnl if this fails we trust it is in the standard include path
+PWD=`pwd`
if test -f $prefix/pd/src/m_pd.h;
then
PD_CPPFLAGS="-I$prefix/pd/src"
@@ -82,9 +84,6 @@ then
elif test -f $prefix/src/pd/src/m_pd.h;
then
PD_CPPFLAGS="-I$prefix/src/pd/src"
-elif test -f $PWD/../../pd/src/m_pd.h;
-then
- PD_CPPFLAGS="-I$PWD/../../pd/src"
elif test -f $PWD/../pd/src/m_pd.h;
then
PD_CPPFLAGS="-I$PWD/../pd/src"
@@ -127,7 +126,7 @@ dnl Darwin specific stuff: this is still pretty experimental
dnl How to test if frameworks are present ????
if test $ARCH == Darwin
then
- PD_EXECUTABLE=$PWD/../../pd/bin/pd
+ PD_EXECUTABLE=$prefix/bin/pd
LIBS="$LIBS -L/sw/lib"
CPPFLAGS="$CPPFLAGS -I/sw/include"
PDP_EXTRA_CPPFLAGS="-I/sw/include"