aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorN.N. <sevyves@users.sourceforge.net>2010-07-09 04:33:33 +0000
committerN.N. <sevyves@users.sourceforge.net>2010-07-09 04:33:33 +0000
commit2ce4778864216af0c1c41457d7ad340007d53c24 (patch)
tree010887d6f0101d574c9c051565f5235ccf590852 /configure.ac
parent7372c2efaf6ac2f68d1fa34d1859b76fb360e259 (diff)
check for opencv libraries
svn path=/trunk/externals/pdp_opencv/; revision=13699
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a0eb73..1d9f989 100755
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,10 @@ AM_SANITY_CHECK
AM_MAINTAINER_MODE
AM_WITH_DMALLOC
+AC_CHECK_LIB(cv, cvSobel, , AC_MSG_ERROR(you need to install opencv library (libcv)))
+AC_CHECK_LIB(highgui, cvNamedWindow, , AC_MSG_ERROR(you need to install high gui library (libhighgui)))
+AC_CHECK_LIB(cvaux, cvSegmentImage, , AC_MSG_ERROR(you need to install opencv auxiliary library (libcvaux) ))
+
echo -n "looking for pd sources (required) ... "
if test -f $PD_DIR/src/m_pd.h
then