aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBryan Jurish <mukau@users.sourceforge.net>2009-02-15 20:41:13 +0000
committerBryan Jurish <mukau@users.sourceforge.net>2009-02-15 20:41:13 +0000
commitd6e8cff18b7895847b3a0890bd2a2b7c3015718e (patch)
tree2bb22496ecca31fd9a857371bd94dec1f9aeb0c7 /Makefile.am
parentfa91a07f8f6ced306f2a42ccfd4c30d478ee11a6 (diff)
+ finished centralization of build logic
svn path=/trunk/externals/moocow/pdstring/; revision=10779
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am82
1 files changed, 11 insertions, 71 deletions
diff --git a/Makefile.am b/Makefile.am
index d0318b3..d3eeb8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,93 +6,33 @@
# Process this file with Automake to create Makefile.in.
#-----------------------------------------------------------------------
-#-----------------------------------------------------------------------
-# Options & Subdirectories
-#-----------------------------------------------------------------------
+##-----------------------------------------------------------------------
+## Options & Subdirectories
+
+##-- aclocal options (top level only)
+ACLOCAL_AMFLAGS = -I m4
-## --- automake options
+## --- automake options (top level only)
#AUTOMAKE_OPTIONS = foreign dist-bzip2 dist-zip
AUTOMAKE_OPTIONS = foreign
## --- recursion subdirectories
SUBDIRS = config src
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .pod .txt
-
#-----------------------------------------------------------------------
-# Variables: cleanup
+# Includes
#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-
-## --- clean: built by 'make'
-#CLEANFILES =
-
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
-
+include $(top_srcdir)/pdexternal.am
#-----------------------------------------------------------------------
# Additional Variables & Rules: PODS
#-----------------------------------------------------------------------
PODS = README.pod
-.pod.txt:
- pod2text $< $@
-
all-local: $(PODS:.pod=.txt)
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
+##-----------------------------------------------------------------------
+## Variables: distribution
## --- extra distribution files
-EXTRA_DIST = \
- $(PODS:.pod=.txt) autogen.sh configure \
- README.cvs COPYING
-
-## --- recursion subdirectories for 'make dist'
-#DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-
+EXTRA_DIST += $(PODS:.pod=.txt)