aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 350fb84..d06b9b4 100644
--- a/configure.in
+++ b/configure.in
@@ -72,7 +72,21 @@ AC_CHECK_HEADERS([string.h],
[/* nonempty includes: compile only */])
-##------- PD externals
+
+##------- PD externals: hack EXEEXT?
+AC_MSG_CHECKING([how to hack automake EXEEXT conventions])
+case "${am__api_version}" in
+ 1.[[0-4]]*)
+ AC_MSG_RESULT([automake v${ap__api_version}: on install])
+ exeext_build=""
+ ;;
+ *)
+ AC_MSG_RESULT([automake v${am__api_version}: on build])
+ exeext_build="\$(EXEEXT)"
+ ;;
+esac
+
+##------- PD externals: hack EXEEXT?
PD_LIB_EXTERNALS="pdstring"
PD_OBJ_EXTERNALS="any2string string2any"
@@ -83,13 +97,13 @@ AC_ARG_ENABLE(object-externals,
AC_MSG_CHECKING([whether to build single-object externals])
##-- always build lib
-PD_OBJECT_EXTERNALS="pdstring\$(EXEEXT)"
+PD_OBJECT_EXTERNALS="pdstring${exeext_build}"
if test "$want_objext" != "no" ; then
##-- single-objects
AC_MSG_RESULT(yes)
for ext in $PD_OBJ_EXTERNALS ; do
- PD_OBJECT_EXTERNALS="$PD_OBJECT_EXTERNALS ${ext}\$(EXEEXT)"
+ PD_OBJECT_EXTERNALS="$PD_OBJECT_EXTERNALS ${ext}${exeext_build}"
done
AC_DEFINE(PDSTRING_OBJECT_EXTERNALS,1,
[Define this if you are building single-object externals])