aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-04 15:56:19 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-04 15:56:19 +0000
commit5640ac0a90ce93e05a31572f1397425907d65332 (patch)
treee87a664effc18eec6fabead524037caa0026dc2d /debian/rules
parentefff703a2759ad6b851497c7abae047dff8a7eb5 (diff)
first stab at debianizing, will need to sort out zexy and moocow dependencies, since they are not libdirs in pd-zexy and pd-pdstringbackups/externals/pduino@16328
svn path=/trunk/externals/pduino/; revision=16327
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..899d6fe
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = arduino
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars