aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorN.N. <sevyves@users.sourceforge.net>2010-07-09 04:29:25 +0000
committerN.N. <sevyves@users.sourceforge.net>2010-07-09 04:29:25 +0000
commit07c9c742b5a7af4994cdccb39750eaf1edd886c2 (patch)
treed938a936d6dfd300ae4db85a7a6d35359cb0ed56 /configure.ac
parent65afab9f9472156ab34e32b921b878499cf3bad3 (diff)
check for opencv libraries
svn path=/trunk/externals/pix_opencv/; revision=13698
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00ef9d7..17780cc 100755
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,10 @@ AM_SANITY_CHECK
AM_MAINTAINER_MODE
AM_WITH_DMALLOC
+AC_CHECK_LIB(cv, cvSobel, , AC_MSG_ERROR(you need to install opencv library (libcv)))
+AC_CHECK_LIB(highgui, cvNamedWindow, , AC_MSG_ERROR(you need to install high gui library (libhighgui)))
+AC_CHECK_LIB(cvaux, cvSegmentImage, , AC_MSG_ERROR(you need to install opencv auxiliary library (libcvaux) ))
+
echo -n "looking for pd sources (required) ... "
if test -f $PD_DIR/src/m_pd.h
then