aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-08-24 15:14:29 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-08-24 15:14:29 +0000
commit2de094bfae5a48374d65f4c273c366b88af85c5b (patch)
tree1e2efa6f68c00a58036872daab00e3d66612b16f /debian/rules
parent20b3e230bce680ec76404a359c67fe176bbf76e5 (diff)
converted to library template and debianized
svn path=/trunk/externals/plugin~/; revision=13938
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b2743ec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = plugin~
+PACKAGE = pd-plugin
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+