aboutsummaryrefslogtreecommitdiff
path: root/psql/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-09-16 18:11:51 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-09-16 18:11:51 +0000
commit240fb90c779cd1c5826b305003a2fe39a5c8cd0c (patch)
treecd9e738d6023fd82a3edcdc50fa041bdb945c487 /psql/debian/rules
parent8e33cbf97588a66c63a77146bb86cf62602bf991 (diff)
first stab at a working debian package
svn path=/trunk/externals/postlude/; revision=16245
Diffstat (limited to 'psql/debian/rules')
-rwxr-xr-xpsql/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/psql/debian/rules b/psql/debian/rules
new file mode 100755
index 0000000..1421ccc
--- /dev/null
+++ b/psql/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = psql
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars