aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-04-09 19:57:15 +0000
committerIOhannes m zmölnig <zmoelnig@iem.at>2015-10-14 14:40:10 +0200
commitd6ba9999928ae41c5e3801c5c271860615b00700 (patch)
tree812404ca7f8d6583c9aa8376c5ed187beee651e8 /debian
parent7fe3362ee2afcd57daa1bb04b1ed6d103a6b5662 (diff)
ported purepd to template Makefile/debian
svn path=/trunk/abstractions/purepd/; revision=13417
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright18
-rwxr-xr-xdebian/rules16
5 files changed, 55 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..28325f5
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-purepd (0.1-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..e57770e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: pd-purepd
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata (>= 0.42.5-3.1~)
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-purepd
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: a library of objects re-implemented using only Pd-vanilla
+ This is a library focused on re-implementing existing objects written in C
+ using only objects that are included in Pd-vanilla. The idea is to provide
+ drop-in replacements for the binary objects usable on any platform.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..ac31d2c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,18 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Tue, 9 Feb 2010 17:14:25 -0400
+Files: *
+Copyright: 1997-1999, Miller Puckette
+ 1997-2002, Dieter Kovacic
+ 2003-2010, Free Software Foundation
+ 2004, Tim Blechmann
+ 2009, IOhannes m. zmoelnig
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2876d32
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = purepd
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+