aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..69c5232
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+##
+
+AUTOMAKE_OPTIONS = foreign
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+ACLOCAL_AMFLAGS = -I m4/generated -I m4
+AM_CPPFLAGS = -I$(top_srcdir)/../../../pd/src
+
+lib_LTLIBRARIES = wiimote.la
+
+SOURCES = wiimote.c
+dist_data_DATA = wiimote-help.pd
+
+
+
+wiimote_la_SOURCES = $(SOURCES)
+wiimote_la_CFLAGS = @ARCH_CFLAGS@ @PD_CFLAGS@
+wiimote_la_LIBADD = $(LIBM)
+wiimote_la_LDFLAGS = -module -avoid-version -shared @ARCH_LDFLAGS@ @PD_LDFLAGS@
+
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status --recheck