aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-09 17:42:45 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-09 17:42:45 +0000
commitc682175c3a49b7377a5ba6c0becf0e24a65bdba7 (patch)
treebb043cc573b76af63c795c1b8ec62e9c4d7882e9 /debian
parent9a082f97a60793ab2e151a70a931977a802de47b (diff)
converted 'windowing' to use the Makefile template+debian stuff
svn path=/trunk/externals/windowing/; revision=13148
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright28
-rwxr-xr-xdebian/rules15
5 files changed, 64 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..cff96a4
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-windowing (0.1-1.1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ef68db8
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: pd-windowing
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), pure-data | pd
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-windowing
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: a library of windowing functions
+ Hanning, Hamming, Blackman, Cosine, Connes, Bartlett, Welch,
+ Lanczos, Gaussian, and Kaiser windowing functions with are
+ applied per-block.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..c63e547
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,28 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Sun, 31 Jan 2010 17:14:25 -0400
+Original-Source: http://crca.ucsd.edu/~jsarlo/pd/windowing.tar.gz
+
+Files: bartlett~.c blackman~.c connes~.c cosine~.c gaussian~.c hamming~.c
+hanning~.c kaiser~.c lanczos~.c welch~.c
+Copyright: Copyright 2002 Joseph A. Sarlo
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
+
+
+Files: kaiser~.c, mconf.h
+Copyright: Copyright 1984, 1987, 1989, 1995, 2000 by Stephen L. Moshier
+Original-Source: http://www.moshier.net/cephes-math-28.tar.gz
+
+License:
+Some software in this archive may be from the book _Methods and
+Programs for Mathematical Functions_ (Prentice-Hall, 1989) or
+from the Cephes Mathematical Library, a commercial product. In
+either event, it is copyrighted by the author. What you see here
+may be used freely but it comes with no support or guarantee.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4c391de
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = windowing
+PACKAGE = pd-$(LIBRARY_NAME)
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=/usr/lib/pd install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)/usr/lib/pd/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+