aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2012-01-17 08:50:13 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2012-01-17 08:50:13 +0000
commit0d1512e0cbb5f95530d41fa4d48fa79bcec87ea5 (patch)
tree41e175db03a10a1ed7bd9789e2ba2522863f2776 /configure.ac
parentccaf14a04445df383990b43ce2c19993e11bb984 (diff)
allow to build simultaneously as library and 1-object-per-file lib
using '--enable-library=both' svn path=/trunk/externals/zexy/; revision=15879
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 46ef99e..337143e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,8 +32,9 @@ AC_PROG_LIBTOOL
AC_ARG_WITH([pd], [ --with-pd=</path/to/pd> where to look for pd-headers and and -libs])
AC_ARG_WITH([extension],[ --with-extension=<ext> enforce a certain extension for the dynamic library (e.g. dll)])
-AC_ARG_ENABLE([library],[ --disable-library split the library into single externals])
+AC_ARG_ENABLE([library],[ --enable-library build zexy as multi-object library (default, "yes"), as single-object externals ("no") or as both ("both")])
AM_CONDITIONAL([LIBRARY], [test "x${enable_library}" != "xno"])
+AM_CONDITIONAL([SINGLEOBJECTS], [test "x${enable_library}" = "xno" || test "x${enable_library}" = "xboth"])
if test "x${libdir}" = "x\${exec_prefix}/lib"; then