aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2005-09-29 08:03:16 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2005-09-29 08:03:16 +0000
commit5ae9dc358a93134d265daedab8d953f7d2f425ac (patch)
treee06cda9db07ec2741f0903d49a593c23c149bc30 /src/configure.ac
parent09a7a4a47485a8fc549a3d89088d74ad6357b6de (diff)
adapted build-system to not use Make.source any longer but generate SOURCES on the fly
added dependency support svn path=/trunk/externals/zexy/; revision=3644
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 2b81b3e..2ca7efc 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -97,6 +97,14 @@ AC_CHECK_HEADERS(stdlib.h stdio.h string.h math.h time.h sys/time.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_TIME
+### make-depend flags
+if test "x$ac_cv_c_compiler_gnu" = "xyes"; then
+ AC_SUBST(MAKEDEP_FLAGS, "-MM")
+else
+ AC_SUBST(MAKEDEP_FLAGS, "-M")
+fi
+
+
dnl Checks for library functions.
AC_FUNC_MMAP
AC_CHECK_FUNCS(select socket strerror)