aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2006-01-24 21:34:48 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2006-01-24 21:34:48 +0000
commitcacdca8b778b4fadfc708f1123f01a2d7e658510 (patch)
tree1428f1f7ac1c8d240fa6942080794f6c844079ab /src/configure.ac
parent0be9cb9aac9019c0ba8f2709e27b3534f5fcaa51 (diff)
fixed enable/disable-flags
put INCLUDES into CFLAGS (in order to have an effect in AC_CHECK_HEADERS() svn path=/trunk/externals/zexy/; revision=4483
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ad64456..42b5b9a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -35,6 +35,22 @@ then
AC_ARG_ENABLE(bundle, [ --enable-bundleloader use bundle_loader (default: autodetect)])
fi
+if test "x" = "x${enable_PIC}" ; then
+ enable_PIC="${with_PIC}"
+fi
+
+if test "x" = "x${enable_lpt}" ; then
+ enable_lpt="${with_lpt}"
+fi
+
+if test "x" = "x${enable_icc}" ; then
+ enable_icc="${with_icc}"
+fi
+
+if test "x" = "x${enable_bundle}" ; then
+ enable_bundle="${with_bundle}"
+fi
+
dnl Checks for libraries.
dnl Replace `main' with a function in -lc:
AC_CHECK_LIB(c, main)
@@ -399,6 +415,8 @@ else
fi
+CFLAGS="${INCLUDES} ${CFLAGS}"
+INCLUDES=""
AC_CHECK_HEADERS(m_pd.h, , AC_ERROR([m_pd.h is desperately needed!
install pd and/or use
"--with-pd=</path/to/pd/>" or