aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 931464f..a0086fd 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -275,7 +275,6 @@ dnl
dnl OK, checks which machines are here now
dnl this needs some rethinking when cross-compiling (?)
dnl
-AC_CHECK_LDFLAGS([-shared])
if test x${KERN} = xLinux;
then
@@ -301,12 +300,10 @@ then
fi
fi
-#AC_CHECK_LDFLAGS([-dynamiclib -mmacosx-version-min=10.3 -undefined dynamic_lookup],
-# ,
-# AC_CHECK_LDFLAGS([-bundle -undefined suppress -flat_namespace])
-# )
-
+# linux
+AC_CHECK_LDFLAGS([-shared -Wl,--export-dynamic])
+#osx
AC_CHECK_LDFLAGS([-bundle -mmacosx-version-min=10.3 -undefined dynamic_lookup],
,
AC_CHECK_LDFLAGS([-dynamiclib -mmacosx-version-min=10.3 -undefined dynamic_lookup],
@@ -317,6 +314,7 @@ AC_CHECK_LDFLAGS([-bundle -mmacosx-version-min=10.3 -undefined dynamic_lookup],
+
if test x${KERN} = xIRIX64; then
LDFLAGS="-n32 -DUNIX -DIRIX -DN32 -woff 1080,1064,1185 \
-OPT:roundoff=3 -OPT:IEEE_arithmetic=3 -OPT:cray_ivdep=true \