aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control24
-rw-r--r--debian/copyright22
-rw-r--r--debian/gbp.conf7
-rw-r--r--debian/links2
-rwxr-xr-xdebian/rules21
-rw-r--r--debian/source/format1
8 files changed, 83 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..9723749
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-libdir (0.0-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0f2108c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,24 @@
+Source: pd-libdir
+Section: libs
+Priority: optional
+Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
+Uploaders: Hans-Christoph Steiner <hans@eds.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata-dev
+Standards-Version: 3.9.1
+Homepage: http://puredata.info
+
+Package: pd-libdir
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: provides support for the libdir library format for Pd
+ The 'libdir' loader is a Pure Data loader which supports the libdir
+ library format. The libdir library format aims to be a common
+ library format for Pd which works with objects written in any
+ language, including Pd. This library format was designed to be easy
+ to create, install, and use. It should work when installed into the
+ global path (i.e. pd/extra) or when copied locally into a project
+ folder. It should work with objects written in any supported language
+ (i.e. binaries, .pd, and the various loaders like pdlua and
+ tclpd). Also, starting with Pd 0.43 and Pd-extended 0.42, the Help
+ Browser dynamically builds itself based on the libraries that are
+ installed.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..488aa95
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,22 @@
+Format-Specification: http://svn.debian.org/wsvn/dep/web/deps/dep5.mdwn?rev=135
+Name: libdir
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Mon, 6 Sep 2010 17:14:25 -0400
+Files: *
+Copyright: 2006-2010, Hans-Christoph Steiner
+
+License: BSD
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+ .
+ On Debian systems, the complete text of the Modified BSD License
+ can be found in file "/usr/share/common-licenses/BSD".
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..baae294
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+upstream-branch = upstream
+debian-branch = master
+upstream-tag = upstream/%(version)s
+debian-tag = debian/%(version)s
+pristine-tar = True
+
diff --git a/debian/links b/debian/links
new file mode 100644
index 0000000..f924517
--- /dev/null
+++ b/debian/links
@@ -0,0 +1,2 @@
+usr/lib/pd/extra/libdir/README.txt usr/share/doc/pd-libdir/README
+usr/share/common-licenses/BSD usr/lib/pd/extra/libdir/LICENSE.txt
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3c49f8e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = libdir
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh --with quilt $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+
+override_dh_strip:
+ strip --remove-section=.comment --remove-section=.note --strip-unneeded \
+ $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)