aboutsummaryrefslogtreecommitdiff
path: root/desiredata/src/configure.in
diff options
context:
space:
mode:
authorN.N. <matju@users.sourceforge.net>2009-04-24 21:16:17 +0000
committerN.N. <matju@users.sourceforge.net>2009-04-24 21:16:17 +0000
commit37f13406bac5f32b4d03d6fcbd75675963e3b8bd (patch)
treebbf3926ff01db4e59eb0bddaf92e2574f947ff4f /desiredata/src/configure.in
parent352562f773de9798c7b2c11679d09c26802ee78c (diff)
i don't remember what those changes were for, but that's how they are in my code for quite a while.
svn path=/trunk/; revision=11131
Diffstat (limited to 'desiredata/src/configure.in')
-rw-r--r--desiredata/src/configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/desiredata/src/configure.in b/desiredata/src/configure.in
index 752551ec..df89a181 100644
--- a/desiredata/src/configure.in
+++ b/desiredata/src/configure.in
@@ -1,11 +1,10 @@
-# This file is part of DesireData
-# If you want to build Thomas Grill's devel_0_39, you need to use scons instead.
-#
+# NOTE!!!
# ./configure is not a source file (not written by someone), it's generated from
# ./configure.in, but it's still put in the CVS and releases so that people don't
# have to have autoconf installed.
-AC_INIT(kernel.c)
+AC_INIT
+AC_CONFIG_SRCDIR([kernel.c])
AC_SUBST(oss, yes)
AC_SUBST(alsa, yes)
AC_SUBST(jack, yes)
@@ -23,6 +22,8 @@ AC_SUBST(EXTERNTARGET)
AC_SUBST(LIBSUFFIX)
AC_SUBST(LDSOFLAGS)
+AC_CONFIG_HEADERS([config.h:config.h.in])
+
dnl Checks for features.
AC_ARG_ENABLE(alsa, [ --enable-oss audio via OSS], alsa=$enableval)
AC_ARG_ENABLE(alsa, [ --enable-alsa audio via ALSA], alsa=$enableval)
@@ -209,5 +210,6 @@ if test x$bigendian = "xyes"; then
CPPFLAGS=$CPPFLAGS" -DBIGENDIAN"
fi
-AC_OUTPUT(makefile)
+AC_CONFIG_FILES([makefile])
+AC_OUTPUT