aboutsummaryrefslogtreecommitdiff
path: root/desiredata/src/configure.in
diff options
context:
space:
mode:
authorN.N. <matju@users.sourceforge.net>2009-05-16 17:57:52 +0000
committerN.N. <matju@users.sourceforge.net>2009-05-16 17:57:52 +0000
commitbd77c496bb0633ba9083d890ce136d9664c4d05c (patch)
tree389de4c7f1b72d96421c9cb6607965e4792510c1 /desiredata/src/configure.in
parentdc7fe364b756c4a77356b32f73d81629e9ef7375 (diff)
hopefully fixes the pdsend/pdreceive compilation problem
svn path=/trunk/; revision=11394
Diffstat (limited to 'desiredata/src/configure.in')
-rw-r--r--desiredata/src/configure.in46
1 files changed, 19 insertions, 27 deletions
diff --git a/desiredata/src/configure.in b/desiredata/src/configure.in
index 8bccc44a..106dd3e6 100644
--- a/desiredata/src/configure.in
+++ b/desiredata/src/configure.in
@@ -27,13 +27,7 @@ AC_SUBST(EXE)
AC_SUBST(WSTRIP)
AC_SUBST(PDSEND)
AC_SUBST(PDRECEIVE)
-
-AC_SUBST(WATCHDOG)
-AC_SUBST(WLIB)
-AC_SUBST(WEXE)
-AC_SUBST(EXE)
-AC_SUBST(PDSEND)
-AC_SUBST(PDRECEIVE)
+AC_SUBST(STRIP)
AC_CONFIG_HEADERS([config.h:config.h.in])
@@ -78,6 +72,9 @@ AC_CHECK_FUNCS(vasprintf)
AUDIOSRC=""
MIDISRC="s_midi_none.c"
+WLIB=""
+STRIP="meuhhhhh"
+
if test `uname -s` = Linux; then
LDFLAGS="-Wl,-export-dynamic "
EXT=pd_linux
@@ -89,7 +86,6 @@ if test `uname -s` = Linux; then
LDSOFLAGS="-shared"
WATCHDOG=pd-watchdog
EXE=""
- WLIB=""
WSTRIP=""
PDRECEIVE=pdreceive
PDSEND=pdsend
@@ -120,7 +116,6 @@ if test `uname -s` = Darwin; then
# fi
WATCHDOG=pd-watchdog
EXE=""
- WLIB=""
WSTRIP=""
PDRECEIVE=pdreceive
PDSEND=pdsend
@@ -134,11 +129,10 @@ if test `uname -s | cut -f1 -d_` = CYGWIN; then
MORECFLAGS="-fno-strict-aliasing"
STRIPFLAG=-s
LDSOFLAGS="-shared"
- WLIB=""
- EXE=.exe
- WSTRIP=""
- PDRECEIVE=pdreceive
- PDSEND=pdsend
+ EXE=.exe
+ WSTRIP=""
+ PDRECEIVE=pdreceive
+ PDSEND=pdsend
fi
if test `uname -s | cut -f1 -d_` = MINGW32; then
@@ -146,23 +140,21 @@ if test `uname -s | cut -f1 -d_` = MINGW32; then
EXT=dll
LIBSUFFIX=.dll
CPPFLAGS="-DMSW \
-# -DUSEAPI_MMIO \
-# -DUSE_PORTAUDIO \
-DPD_INTERNAL -DPD "
MORECFLAGS="-mms-bitfields"
STRIPFLAG=-s
LDSOFLAGS="-shared"
-# AUDIOSRC="s_audio_mmio.c"
- MIDISRC="s_midi_mmio.c"
-
- STRIP="strip --strip-unneeded -R .note -R .comment"
- EXPORT="-Wl, --export-all-symbols -Wl, --out-implib=pd.a"
- WLIB=$WLIB"$LDFLAGS $EXPORT; $STRIP libpd.dll"
- PDRECEIVE="$LDFLAGS; $STRIP pdreceive.exe"
- PDSEND="$LDFLAGS; $STRIP pdsend.exe"
- EXE=.exe
- WATCHDOG=pd.com
- WSTRIP=$STRIP $DESTDIR$bindir/pd.exe
+# AUDIOSRC="s_audio_mmio.c"
+ MIDISRC="s_midi_mmio.c"
+
+ STRIP="strip --strip-unneeded -R .note -R .comment"
+ EXPORT="-Wl, --export-all-symbols -Wl, --out-implib=pd.a"
+ WLIB=$WLIB"$LDFLAGS $EXPORT; $STRIP libpd.dll"
+ PDRECEIVE="$LDFLAGS; $STRIP pdreceive.exe"
+ PDSEND="$LDFLAGS; $STRIP pdsend.exe"
+ EXE=.exe
+ WATCHDOG=pd.com
+ WSTRIP=$STRIP $DESTDIR$bindir/pd.exe
fi
if test `uname -m` = x86_64; then