aboutsummaryrefslogtreecommitdiff
path: root/externals/debian
diff options
context:
space:
mode:
authorGuenter Geiger <ggeiger@users.sourceforge.net>2003-11-05 11:27:31 +0000
committerGuenter Geiger <ggeiger@users.sourceforge.net>2003-11-05 11:27:31 +0000
commit789fdddb0df603674a086e1c4c6c49623b2f510d (patch)
tree6ac6e7e720a0846b5bb6403285471ffc944e669d /externals/debian
parent9fa596ec9b3614aaa92ff3d408540a32eb84ca1f (diff)
updated for new version, removed pdp
svn path=/trunk/; revision=1167
Diffstat (limited to 'externals/debian')
-rw-r--r--externals/debian/changelog7
-rw-r--r--externals/debian/pd-flext-ext.files6
-rw-r--r--externals/debian/pd-zexy.files1
-rwxr-xr-xexternals/debian/rules35
4 files changed, 23 insertions, 26 deletions
diff --git a/externals/debian/changelog b/externals/debian/changelog
index 641d46cc..99dfabf9 100644
--- a/externals/debian/changelog
+++ b/externals/debian/changelog
@@ -1,3 +1,10 @@
+pd-externals (00.20031105) unstable; urgency=low
+
+ * New snapshot
+ * removed pdp (will be separate package)
+
+ -- Guenter Geiger (Debian/GNU) <geiger@debian.org> Mon, 05 Nov 2003 17:49:15 +0200
+
pd-externals (00.20030718-1) unstable; urgency=low
* new release, with cyclone
diff --git a/externals/debian/pd-flext-ext.files b/externals/debian/pd-flext-ext.files
index 46a5b909..ed40d054 100644
--- a/externals/debian/pd-flext-ext.files
+++ b/externals/debian/pd-flext-ext.files
@@ -2,6 +2,6 @@
/usr/lib/pd/extra/shaffy*
/usr/lib/pd/extra/syncgrain~.pd_linux
/usr/lib/pd/extra/fluid*
-/usr/lib/pd/doc/5.reference/help-fluid.pd
-/usr/lib/pd/doc/5.reference/help-shaffy~.pd
-/usr/lib/pd/doc/5.reference/help-shabby~.pd
+/usr/lib/pd/doc/5.reference/*fluid*.pd
+/usr/lib/pd/doc/5.reference/*shaffy~*.pd
+/usr/lib/pd/doc/5.reference/*shabby~*.pd
diff --git a/externals/debian/pd-zexy.files b/externals/debian/pd-zexy.files
index 5529519d..1e08798c 100644
--- a/externals/debian/pd-zexy.files
+++ b/externals/debian/pd-zexy.files
@@ -1,4 +1,3 @@
usr/lib/pd/extra/zexy*
usr/lib/pd/doc/5.reference/zexy
-usr/lib/pd/doc/5.reference/help-zexy
diff --git a/externals/debian/rules b/externals/debian/rules
index 9ff6cbe6..e6587efe 100755
--- a/externals/debian/rules
+++ b/externals/debian/rules
@@ -119,13 +119,19 @@ install: build
dh_installdirs
# Add here commands to install the package into debian/pd-externals.
+
(cd build/linux; $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp)
(rm -r `find $(CURDIR)/debian/tmp/ -name CVS`)
+# Install zexy
+
(cd zexy/src; $(MAKE) -f makefile.linux install DESTDIR=$(CURDIR)/debian/tmp \
INSTALL_PREFIX=/usr/ \
PDLIBDIR=lib/pd )
- ln -s zexy $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/help-zexy
+# ln -s zexy $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/help-zexy
+
+# Install flext
+
(cd grill/flext; $(MAKE) -f makefile.pd-linux install INSTDIR=$(CURDIR)/debian/tmp/usr/lib/pd/flext)
# Install footils ... this is quite messy still, have to find a better solution
@@ -133,18 +139,17 @@ install: build
(make -C footils/fluid -k $(FOOINSTALL) install)
(make -C footils/shabby -k $(FOOINSTALL) install)
(make -C footils/syncgrain -k $(FOOINSTALL) install)
- install -m 644 footils/fluid/pd/fluid.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/help-fluid.pd
- install -m 644 footils/shabby/shaffy~-help.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/help-shaffy~.pd
- install -m 644 footils/shabby/shabby~.pd_linux $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/help-shabby~.pd
+ install -m 644 footils/fluid/pd/fluid.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference/fluid-help.pd
+ install -m 644 footils/shabby/shaffy~-help.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference
+ install -m 644 footils/shabby/shabby~.pd_linux $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference
-rm $(CURDIR)/debian/tmp/usr/lib/pd/extra/fiiwu*
-
- # Install OSC
+# Install OSC
install OSCx/OSC/OSC.pd_linux $(CURDIR)/debian/tmp/usr/lib/pd/extra
- install -m 644 OSCx/doc/*.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference
+ install -m 644 OSCx/doc/*help.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference
- # Install cyclone
+# Install cyclone
mkdirhier $(CURDIR)/debian/tmp/usr/lib/pd/externs/cyclone
install $(CURDIR)/miXed/bin/*.pd_linux $(CURDIR)/debian/tmp/usr/lib/pd/externs/cyclone/
@@ -152,20 +157,6 @@ install: build
install -m 644 $(CURDIR)/miXed/test/cyclone/*.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/cyclone
- # Clean up make references
-
- (cd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference; \
- for i in *.pd; do\
- if [ "$$i" = "$${i#help-*}" ]; then\
- mv $$i help-$$i;\
- fi;\
- done)
-
- # A good thought to move references to their right place, but finally,
- # this doesn't work, so move abstractions that are used by references
- # back to their right place ... damn.
-
-
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.