aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/tutorial/sndobj1/Makefile.am
diff options
context:
space:
mode:
authorThomas Grill <xovo@users.sourceforge.net>2005-01-06 04:59:21 +0000
committerThomas Grill <xovo@users.sourceforge.net>2005-01-06 04:59:21 +0000
commited4ce25dc69fd6361f7655a3ab5d05186754316c (patch)
tree39f14a7ccb5116b0368a921944469f747e95c1d0 /externals/grill/flext/tutorial/sndobj1/Makefile.am
parentaeb9247272c2772c491df8f682aebf0097c98519 (diff)
build system for flext-based externals
reconsidered flext::buffer:Update improved buffer handling added object construction and destruction flags updated autoconf system updated documentation updated build system svn path=/trunk/; revision=2467
Diffstat (limited to 'externals/grill/flext/tutorial/sndobj1/Makefile.am')
-rw-r--r--externals/grill/flext/tutorial/sndobj1/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/externals/grill/flext/tutorial/sndobj1/Makefile.am b/externals/grill/flext/tutorial/sndobj1/Makefile.am
index eb7ac446..2c9b1436 100644
--- a/externals/grill/flext/tutorial/sndobj1/Makefile.am
+++ b/externals/grill/flext/tutorial/sndobj1/Makefile.am
@@ -8,20 +8,20 @@ NAME = sndobj1
BUILT_SOURCES = main.cpp
EXTRA_DIST = main.cpp \
- $(NAME).cw \
- $(NAME).dsp \
+ $(NAME).mcp \
$(NAME).vcproj
CXXFLAGS = @CXXFLAGS@ \
@OPT_FLAGS@ \
@INCLUDEDIR@ \
-I../../source \
- $(DEFS)
+ $(DEFS) \
+ -DFLEXT_SHARED
LDFLAGS = @LDFLAGS@ \
$(patsubst %,-framework %,$(FRAMEWORKS))
-LIBS = @LIBS@
+LIBS = @LIBS@ -lflext
FRAMEWORKS = @FRAMEWORKS@
@@ -36,9 +36,8 @@ SYSDIR = @SYSDIR@
# ----------------------------- targets --------------------------------
-if SNDOBJ
all-local: $(OBJECTS)
- $(CXX) $(LDFLAGS) -shared ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
+ $(CXX) $(LDFLAGS) ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
strip --strip-unneeded ../$(TARGETDIR)/$(TARGET)
./%.@OBJEXT@ : %.cpp
@@ -50,4 +49,3 @@ clean-local:
install-exec-local:
install ../$(TARGET) $(SYSDIR)extra
-endif \ No newline at end of file