aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-02 20:25:38 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-02 20:25:38 +0000
commit0e106cf0718eaaf2c9b5fae9631e14acb8de8d03 (patch)
tree8b328563cd296c6a08dcc0652988ebe87e013004 /packages/Makefile.buildlayout
parent9824911696452b978cb3df750527d6c7ee2d9853 (diff)
added LN_S variable so it can be set to 'cp -a' on MinGW
svn path=/trunk/; revision=15456
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index e927c4e5..53a1a155 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -41,21 +41,25 @@ ifeq ($(UNAME),Linux)
OS_NAME = linux
EXTENSION = pd_linux
DYLIB_EXTENSION = so
+ LN_S = ln -s
endif
ifeq ($(UNAME),Darwin)
OS_NAME = darwin
EXTENSION = pd_darwin
DYLIB_EXTENSION = dylib
+ LN_S = ln -s
endif
ifeq (MINGW,$(findstring MINGW,$(UNAME)))
OS_NAME = windows
EXTENSION = dll
DYLIB_EXTENSION = dll
+ LN_S = cp -a
endif
ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
OS_NAME = windows
EXTENSION = dll
DYLIB_EXTENSION = dll
+ LN_S = ln -s
endif
# which CPU to compile for
UNAME_MACHINE := $(shell uname -m)