aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2008-05-10 18:54:22 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2008-05-10 18:54:22 +0000
commit177fa2d8ad04f93ae5411d5c3a8c715cf5ea4534 (patch)
tree688f3e89b57c6edb55bb5b6c8ac816da1c59576d /packages/Makefile.buildlayout
parent7af7b50ff3e1cebb484eb7d0d241bfb34b0212cb (diff)
fixed up Debian packages so that they now installed properly into /usr rather than /usr/local. The tarballs still install into /usr/local. Also limited the dpkg commands to machines that have dpkg-deb installed. Also, tweaked /usr/share/pd to be write-all so that people can install their own stuff there.
svn path=/trunk/; revision=9778
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 7f2c3a31..dd4a00e6 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -68,6 +68,12 @@ endif
ifeq ($(UNAME_MACHINE),ppc)
ARCH = powerpc
endif
+# if machine has dpkg-deb, build a Debian package
+ifeq ($(shell test -x /usr/bin/dpkg-deb && echo YES),YES)
+ PACKAGE_TYPE = deb
+else
+ PACKAGE_TYPE = tarbz2
+endif
#==============================================================================#
#