aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-14 02:48:46 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-14 02:48:46 +0000
commit662a2b342e5583388152716910181ee4549455f6 (patch)
treed743e578a622bf10bd94537027631bf0be372557 /packages/Makefile.buildlayout
parentf2a776440750a0e27fe1b554b613b230521f45fd (diff)
added var to support building shared libraries for libdirs
svn path=/trunk/; revision=8999
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 4e16ebc2..7f2c3a31 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -40,18 +40,22 @@ UNAME := $(shell uname -s)
ifeq ($(UNAME),Linux)
OS_NAME = linux
EXTENSION = pd_linux
+ DYLIB_EXTENSION = so
endif
ifeq ($(UNAME),Darwin)
OS_NAME = darwin
EXTENSION = pd_darwin
+ DYLIB_EXTENSION = dylib
endif
ifeq (MINGW,$(findstring MINGW,$(UNAME)))
OS_NAME = windows
EXTENSION = dll
+ DYLIB_EXTENSION = dll
endif
ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
OS_NAME = windows
EXTENSION = dll
+ DYLIB_EXTENSION = dll
endif
# which CPU to compile for
UNAME_MACHINE := $(shell uname -m)