aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-03 02:14:12 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-03 02:14:12 +0000
commit7a6e85a7dcc211fe7fd76aece3fe07d0dfdf4dbf (patch)
tree773df08f90158b12f3ab8d73ffb306a3c32906a6 /packages/Makefile.buildlayout
parent1397deae838c892b710ccccaf61889dd802367e6 (diff)
oops sorry, I forgot about the whackiness of makefiles, you can't reuse variables!
svn path=/trunk/; revision=8925
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index a8cfbb74..4e16ebc2 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -54,14 +54,14 @@ ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
EXTENSION = dll
endif
# which CPU to compile for
-UNAME := $(shell uname -m)
-ifeq ($(UNAME),i386)
+UNAME_MACHINE := $(shell uname -m)
+ifeq ($(UNAME_MACHINE),i386)
ARCH = i386
endif
-ifeq ($(UNAME),i686)
+ifeq ($(UNAME_MACHINE),i686)
ARCH = i386
endif
-ifeq ($(UNAME),ppc)
+ifeq ($(UNAME_MACHINE),ppc)
ARCH = powerpc
endif