aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-27 17:45:54 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-27 17:45:54 +0000
commit936035a5b422820e3a021370627388357d6cb87e (patch)
tree8d4d2915ad296bfdff88f773c3869a31c30f44eb /packages/Makefile.buildlayout
parent979bf4b7cb7b2a48529644ba758e7a62e11ceac5 (diff)
added patch to completely fix the versioning and move the PD_VERSION replacement to 'make install'; 'make unpatch_pd' now does the reverse of 'make patch_pd'; and PD_TEST_VERSION is now retrieved from m_pd.h
svn path=/trunk/; revision=4623
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 7d31735c..2971545c 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -146,9 +146,12 @@ PD_MINOR_VERSION := $(shell grep PD_MINOR_VERSION $(pd_src)/src/m_pd.h | \
sed 's|^.define *PD_MINOR_VERSION *\([0-9]*\).*|\1|' )
PD_BUGFIX_VERSION := $(shell grep PD_BUGFIX_VERSION $(pd_src)/src/m_pd.h | \
sed 's|^.define *PD_BUGFIX_VERSION *\([0-9]*\).*|\1|' )
-
-PD_VERSION = $(PD_MAJOR_VERSION).$(PD_MINOR_VERSION).$(PD_BUGFIX_VERSION)
-
+PD_TEST_VERSION := $(shell grep PD_TEST_VERSION $(pd_src)/src/m_pd.h | \
+ sed 's|^.define *PD_TEST_VERSION *"\(.*\)".*|\1|' )
+PD_VERSION := $(PD_MAJOR_VERSION).$(PD_MINOR_VERSION).$(PD_BUGFIX_VERSION)
+ifneq ($(PD_TEST_VERSION),)
+ PD_VERSION := $(PD_VERSION)-$(PD_TEST_VERSION)
+endif
# release version for this distro
PACKAGE_VERSION = extended-test1