aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-16 23:01:15 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-16 23:01:15 +0000
commit9a683c2f8610b32ecc80fe256b1226568fcb95c5 (patch)
tree6bd8f6daa2dc1e12fb678f7a324b3eaf4ac8a8ae /packages/Makefile.buildlayout
parent44337cf4e6ed49c291762017d591fc538ab5abcb (diff)
made a unique name for the build layout Makefile to make it distinct from other Makefiles
svn path=/trunk/; revision=3948
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
new file mode 100644
index 00000000..1fa2a0fc
--- /dev/null
+++ b/packages/Makefile.buildlayout
@@ -0,0 +1,47 @@
+
+# this file should be exactly the same in each section of the CVS. A copy is
+# kept in each section of the CVS so that each section will be
+# self-contained. <hans@at.or.at>
+
+# $(INSTALL_PREFIX) and $(SRC_ROOT_DIR) are set in Makefile
+
+# sources
+ABSTRACTIONS_SRC = $(SRC_ROOT_DIR)/abstractions
+DOC_SRC = $(SRC_ROOT_DIR)/doc
+EXTERNALS_SRC = $(SRC_ROOT_DIR)/externals
+FLEXT_SRC = $(SRC_ROOT_DIR)/externals/grill/flext
+GEM_SRC = $(SRC_ROOT_DIR)/Gem
+GEMLIBS_SRC = $(SRC_ROOT_DIR)/GemLibs
+PD_SRC = $(SRC_ROOT_DIR)/pd
+SCRIPTS_SRC = $(SRC_ROOT_DIR)/scripts
+
+
+# destinations
+APPLICATIONS_DEST = $(DOCS_DEST)/examples
+DOCS_DEST = $(INSTALL_PREFIX)/doc
+OBJECTS_DEST = $(INSTALL_PREFIX)/extra
+HELP_DEST = $(DOCS_DEST)/5.reference
+MANUALS_DEST = $(DOCS_DEST)/manuals
+
+#------------------------------------------------------------------------------#
+# DIRECTORY STRUCTURE TARGETS
+#------------------------------------------------------------------------------#
+# first make sure that the directory structure is setup
+$(INSTALL_PREFIX):
+ install -d $(INSTALL_PREFIX)
+
+$(APPLICATIONS_DEST): $(INSTALL_PREFIX)
+ install -d $(APPLICATIONS_DEST)
+
+$(DOCS_DEST): $(INSTALL_PREFIX)
+ install -d $(DOCS_DEST)
+
+$(HELP_DEST): $(INSTALL_PREFIX)
+ install -d $(HELP_DEST)
+
+$(MANUALS_DEST): $(INSTALL_PREFIX)
+ install -d $(MANUALS_DEST)
+
+$(OBJECTS_DEST): $(INSTALL_PREFIX)
+ install -d $(OBJECTS_DEST)
+