aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-01 03:44:12 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-11-01 03:44:12 +0000
commitb8a43458998e2e87e39da7ccbaa16af7d8904dc0 (patch)
tree78f8fb628bb379de7a74f9dc4815643cc7145a60 /packages/Makefile.buildlayout
parent0485340c7e4f8af2dd70f70ba613b3d5bd20e6a6 (diff)
created standard variable for the CPU type to support doing CPU-specific optimizations
svn path=/trunk/; revision=8921
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout11
1 files changed, 11 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 0adee029..a8cfbb74 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -53,6 +53,17 @@ ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
OS_NAME = windows
EXTENSION = dll
endif
+# which CPU to compile for
+UNAME := $(shell uname -m)
+ifeq ($(UNAME),i386)
+ ARCH = i386
+endif
+ifeq ($(UNAME),i686)
+ ARCH = i386
+endif
+ifeq ($(UNAME),ppc)
+ ARCH = powerpc
+endif
#==============================================================================#
#