aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-27 07:12:47 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-27 07:12:47 +0000
commitf1697ad27d0548662cf0a6633f4671cd55b38ab9 (patch)
treee85f9e8a71569bac44dd2194214b8afd40d4d806 /packages/Makefile.buildlayout
parent628cef3d336f0e8e43c1d662a568065054af3b18 (diff)
fixed app renaming so that you can properly rename the Pd.app with one setting; fixed Pd version regexps to look in m_pd.h after complete_version_defines-0.39.2.patch is applied; upgraded to TclTk 8.4.10 and make automatic Wish.app/Wish Shell.app name handling
svn path=/trunk/; revision=4620
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout14
1 files changed, 7 insertions, 7 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 2ec384cd..7d31735c 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -140,13 +140,13 @@ installdirs: $(DESTDIR) $(bindir) $(examplesdir) $(pddocdir) $(includedir) $(hel
#==============================================================================#
-PD_MAJOR_VERSION := $(shell grep 'Pd version' $(pd_src)/src/s_main.c | \
- sed 's/char pd_version\[\] = "Pd version \([0-9]\)\.[0-9]*[. TES-]*[0-9]*[0-9extndRC.-]*.n";/\1/')
-PD_MINOR_VERSION := $(shell grep 'Pd version' $(pd_src)/src/s_main.c | \
- sed 's/char pd_version\[\] = "Pd version [0-9]\.\([0-9]*\)[. TES-]*\([0-9]*\)[0-9extndRC.-]*.n";/\1/')
-PD_BUGFIX_VERSION := $(shell grep 'Pd version' $(pd_src)/src/s_main.c | \
- sed 's/char pd_version\[\] = "Pd version [0-9]\.[0-9]*[. TES-]*\([0-9]*\)[0-9extndRC.-]*.n";/\1/')
-# the separators [.-] need to be the same as in s_main.c or the regexps break
+PD_MAJOR_VERSION := $(shell grep PD_MAJOR_VERSION $(pd_src)/src/m_pd.h | \
+ sed 's|^.define *PD_MAJOR_VERSION *\([0-9]*\).*|\1|' )
+PD_MINOR_VERSION := $(shell grep PD_MINOR_VERSION $(pd_src)/src/m_pd.h | \
+ sed 's|^.define *PD_MINOR_VERSION *\([0-9]*\).*|\1|' )
+PD_BUGFIX_VERSION := $(shell grep PD_BUGFIX_VERSION $(pd_src)/src/m_pd.h | \
+ sed 's|^.define *PD_BUGFIX_VERSION *\([0-9]*\).*|\1|' )
+
PD_VERSION = $(PD_MAJOR_VERSION).$(PD_MINOR_VERSION).$(PD_BUGFIX_VERSION)