aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-05 23:18:36 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-05 23:18:36 +0000
commit4118d41232b8a767d5acd273e88165050edb7ff4 (patch)
treed3c023039bd76b00c4ed82c5dc5c9dd49eed03c2 /packages/Makefile
parentb20a46613ffa4af3604e07689e687ba31cf5e620 (diff)
fixed up doc_format to remove .svn and removed old strip_hack; fixed Pd.app perms; added configure flags to Gem to try to get artlookit working
svn path=/trunk/; revision=11690
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 0a234fd9..08006080 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -224,10 +224,11 @@ $(gem_src)/src/Gem.pd_darwin:
cd $(gem_src)/src && aclocal
cd $(gem_src)/src && autoconf
cd $(gem_src)/src && ./configure \
- --without-x --without-ImageMagick \
+ --without-x --without-ImageMagick --without-v4l \
--without-tiff --without-jpeg --without-mpeg --without-mpeg3 \
--without-ieee1394 --without-aviplay --without-avifile --without-ffmpeg \
--with-ftgl-includes=/sw/include --with-ftgl-libs=/sw/lib \
+ --with-artoolkit-includes=/sw/include --with-artoolkit-libs=/sw/lib \
--with-pd=$(pd_src)
$(MAKE) -C $(gem_src)/src
@@ -439,25 +440,12 @@ endif
#----------------------------------------------------------------------------
-# DOC_FORMAT
+# clean up the documentation before packaging
doc_format:
# clean out cruft files
-find $(DESTDIR) -name .DS_Store -delete
-find $(DESTDIR) -name '*.*.bak' -delete
-# run script to move help-*.pd files to *-help.pd according to the standard
- cd $(helpdir) && \
- $(scripts_src)/convert-help-to-standard.sh
-
-
-
-#----------------------------------------------------------------------------
-# STRIP_HACK
-# not all of the build systems are stripping the externals, so strip them here.
-# Gem, xsample, and some other things don't like to be stripped
-strip_hack:
- $(STRIP) $(objectsdir)/*/*.$(EXTENSION)
- $(STRIP) $(objectsdir)/[A-FH-Za-wyz]*.$(EXTENSION)
-
+ -find $(DESTDIR) -name .svn -print0 | xargs -0 rm -rf
#==============================================================================#