aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-10-17 04:35:14 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-10-17 04:35:14 +0000
commit678d3d225d22dc281de5ceacb52d05299b070cc4 (patch)
tree4485a443d87065c2cc4d657bb59c0fdee22b5369 /packages/Makefile
parentfd6a8ff39988cb8783e4b9c000b18442dd507fdc (diff)
switched test version number to use the current date
svn path=/trunk/; revision=6119
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile33
1 files changed, 22 insertions, 11 deletions
diff --git a/packages/Makefile b/packages/Makefile
index bf0e71db..6d65ff0f 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -779,6 +779,21 @@ devsymlinks_clean:
-sudo rm -f /usr/local/lib/libtclstub*.a /usr/local/lib/libtkstub*.a
+set_version:
+# change Pd's version number to reflect the extended build
+# this needs the complete_version_defines patch to work
+ cd $(pd_src)/src/ && \
+ sed 's|^\(#define PD_TEST_VERSION "\).*"|\1$(PACKAGE_VERSION)"|' m_pd.h > \
+ m_pd.h.tmp && mv m_pd.h.tmp m_pd.h
+
+unset_version:
+# change the version number back to the original
+# this needs the complete_version_defines patch to work
+ cd $(pd_src)/src && \
+ sed 's|^\(#define PD_TEST_VERSION ".*\)$(PACKAGE_VERSION_PREFIX).*"|\1"|' \
+ m_pd.h > m_pd.h.tmp && \
+ mv m_pd.h.tmp m_pd.h
+
patch_pd:
@echo pd_src $(pd_src)
@@ -795,22 +810,11 @@ ifneq ($(OS_NAME),windows)
done
endif
-rm -f -- $(pd_src)/src/configure $(pd_src)/src/makefile
-# change Pd's version number to reflect the extended build
-# this needs the complete_version_defines patch to work
- cd $(pd_src)/src/ && \
- sed 's|^\(#define PD_TEST_VERSION "\).*"|\1$(PACKAGE_VERSION)"|' m_pd.h > \
- m_pd.h.tmp && mv m_pd.h.tmp m_pd.h
@echo " "
@echo "patching completed."
unpatch_pd:
-# change the version number back to the original
-# this needs the complete_version_defines patch to work
- cd $(pd_src)/src && \
- sed 's|^\(#define PD_TEST_VERSION ".*\)$(PACKAGE_VERSION)"|\1"|' \
- m_pd.h > m_pd.h.tmp && \
- mv m_pd.h.tmp m_pd.h
# apply all platform-specific patches
for patch in $(shell ls -1r $(CWD)/patches/$(OS_NAME)/*.patch); do \
echo "Applying $$patch"; \
@@ -825,6 +829,13 @@ unpatch_pd:
@echo " "
@echo "unpatching completed."
+
+patch: patch_pd set_version
+
+unpatch: unset_version unpatch_pd
+
+
+
patch_pd_devel:
@echo pd_src $(pd_src)
# apply all platform-neutral patches