aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-18 06:14:23 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-18 06:14:23 +0000
commit6bcb9aa9966f10273ce083cee52af1896bddfd26 (patch)
tree0a6fe4e2f8c0bc9027e07b19ef5e127468a77e26 /packages/Makefile
parentc37876599e8757700f5fd6137e12232d1691b7a2 (diff)
tweaked things to allow for setting CPU-specific build flags
svn path=/trunk/; revision=6937
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 6045ea6f..91e95b54 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -263,9 +263,10 @@ $(pd_src)/src/configure: $(pd_src)/src/configure.in
#$(pd_src)/src/makefile: $(pd_src)/src/makefile.in
# cd $(pd_src)/src/ && ./configure $(PD_CONFIGURE_FLAGS)
+# this line has the "-" to support the current makefile.mingw hack
pd: $(pd_src)/src/configure
- echo $$MACOSX_DEPLOYMENT_TARGET
-cd $(pd_src)/src && ./configure $(PD_CONFIGURE_FLAGS) && \
+ make OPT_CFLAGS="" depend && \
make $(DEST_PATHS) $(PD_BUILD_FLAGS)
pd++: