aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-26 01:52:47 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-26 01:52:47 +0000
commit6c271c12023d3aff3e5043a456b156b68042738d (patch)
tree270582907b167f8075ecac3fdb231dbc01f4b8f4 /packages/Makefile
parent59bc5841c63961260c70979877df3fc781f8cf30 (diff)
added in Jamie's dlopn patch so I can use his binaries; fixed a number of bugs reported on the list; added platform-specific noncvs handling
svn path=/trunk/; revision=4035
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile58
1 files changed, 42 insertions, 16 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 5316b2e7..ca503f54 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -130,6 +130,7 @@ flext:
#------------------------------------------------------------------------------
# Gem
gem:
+# cd $(GEM_SRC)/Gem && xcodebuild
#------------------------------------------------------------------------------
@@ -180,18 +181,25 @@ pd:
#==============================================================================#
#------------------------------------------------------------------------------
-# abstractions
+# install
+install: license_install readme_install welcome_install gem_install
+install: pd_install abstractions_install doc_install externals_install
+install: noncvs_install
+ @echo "Complete install succeeded!"
+
+#------------------------------------------------------------------------------
+# abstractions_install
abstractions_install:
cd $(ABSTRACTIONS_SRC) && make $(DEST_PATHS) install
#------------------------------------------------------------------------------
-# doc
+# doc_install
doc_install:
cd $(DOC_SRC) && make $(DEST_PATHS) install
#------------------------------------------------------------------------------
-# externals
+# externals_install
externals_install:
cd $(EXTERNALS_SRC) && make $(DEST_PATHS) install
@@ -210,12 +218,38 @@ flext_install:
#------------------------------------------------------------------------------
-# Gem
-gem_install:
+# gem_install
+GEM_NAME = gem
+gem_install: gem $(HELP_DEST)
+ install -p $(GEM_SRC)/help/*.* $(HELP_DEST)
+ install -p $(GEM_SRC)/abstractions/*-help.pd $(HELP_DEST)
+ install -d $(OBJECTS_DEST)/$(GEM_NAME)
+ install -p $(shell ls -1 $(GEM_SRC)/abstractions/*.* | \
+ grep -v '\-help.pd') $(OBJECTS_DEST)
+ install -d $(MANUALS_DEST)/$(GEM_NAME)
+ install -p $(GEM_SRC)/doc/*.* $(MANUALS_DEST)/$(GEM_NAME)
+ install -d $(MANUALS_DEST)/$(GEM_NAME)/manual
+ install -p $(GEM_SRC)/manual/*.* $(MANUALS_DEST)/$(GEM_NAME)/manual
+ for dir in $(shell ls -1 $(GEM_SRC)/examples | grep -v CVS); do \
+ echo "installing $$dir"; \
+ install -d $(APPLICATIONS_DEST)/$(GEM_NAME)/$$dir ; \
+ install -p $(GEM_SRC)/examples/$$dir/*.* $(APPLICATIONS_DEST)/$(GEM_NAME)/$$dir ; \
+ done
#------------------------------------------------------------------------------
-# pd
+# noncvs_install
+# this is for including pre-compiled binaries in a build
+noncvs_install:
+ -install -p $(PACKAGES_SRC)/noncvs/$(OS_NAME)/bin/*.* $(BIN_DEST)
+ -install -p $(PACKAGES_SRC)/noncvs/$(OS_NAME)/doc/5.reference/*.* \
+ $(HELP_DEST)
+ -install -p $(PACKAGES_SRC)/noncvs/$(OS_NAME)/extra/*.* $(OBJECTS_DEST)
+
+
+
+#------------------------------------------------------------------------------
+# pd_install
PD_NAME=Pd
pd_install: pd
cd $(PD_SRC)/src && \
@@ -224,14 +258,6 @@ pd_install: pd
install -p $(PD_SRC)/src/notes.txt $(MANUALS_DEST)/$(PD_NAME)
-#------------------------------------------------------------------------------
-# install
-install: license_install readme_install welcome_install
-install: pd_install abstractions_install doc_install externals_install
-#install: flext_install gem_install
- @echo "Complete install succeeded!"
-
-
#==============================================================================#
#
@@ -340,10 +366,10 @@ doc_format:
# run script to move help-*.pd files to *-help.pd according to the standard
cd $(DOCS_DEST) && \
$(SCRIPTS_SRC)/convert-help-to-standard.sh
-#----------------------------------------------------------------------------
# remove write perms to prevent people form editing the helpfiles by mistake
cd $(DOCS_DEST) && chmod a-wx */*.pd */*/*.pd
- cd $(DOCS_DEST) && chmod a-w ????*/*.* *.txt
+ find $(DOCS_DEST) -name '*.pd' -print0 | xargs -0 chmod a-wx
+ find $(DOCS_DEST) -name '*.txt' -print0 | xargs -0 chmod a-wx