aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-22 06:13:49 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-22 06:13:49 +0000
commit778c90c2f187cdb4e311ca96c9aea626313370a7 (patch)
tree1d077555659712023a3d3620fdbf77167909a2c4 /packages/Makefile
parent1eabfbfa0df32e2f2d6b2f8e71fb516ccc812672 (diff)
version is now all defined in macros in m_pd.h in the complete_version_defines patch, and the regexps in packages/Makefile now rely on that patch
svn path=/trunk/; revision=4608
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 79db6132..b2ed5b50 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -652,19 +652,21 @@ patch_pd:
done
-rm -f -- $(pd_src)/src/configure $(pd_src)/src/makefile
# change Pd's version number to reflect the extended build
+# this needs the complete_version_defines patch to work
cd $(pd_src)/src/ && \
- sed 's/\(pd_version\[\] = "Pd version \)[0-9extndRC.-]*/\1$(PD_VERSION)-$(PACKAGE_VERSION)/' s_main.c > s_main.c.tmp && \
- mv s_main.c.tmp s_main.c
+ sed 's|^\(#define PD_TEST_VERSION "\).*"|\1$(PACKAGE_VERSION)"|' m_pd.h > \
+ m_pd.h.tmp && mv m_pd.h.tmp m_pd.h
@echo " "
@echo "patching succeeded!"
unpatch_pd:
-# this sed pattern won't work with TEST versions
+# change the version number back to the original
+# this needs the complete_version_defines patch to work
cd $(pd_src)/src && \
- sed 's/\(pd_version\[\] = "Pd version [0-9]\.[0-9]*[.-][0-9]*\)[0-9extndRC.-]*/\1/' \
- s_main.c > s_main.c.tmp && \
- mv s_main.c.tmp s_main.c
+ sed 's|^\(#define PD_TEST_VERSION ".*\)$(PACKAGE_VERSION)"|\1"|' \
+ m_pd.h > m_pd.h.tmp && \
+ mv m_pd.h.tmp m_pd.h
# apply all platform-specific patches
for patch in $(wildcard $(CWD)/patches/$(OS_NAME)/*.patch); do \
echo "Applying $$patch"; \