aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-04-16 18:17:32 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-04-16 18:17:32 +0000
commitadf8f7a6ee30f5bfb2b0fecd1d212dddb0caa1b4 (patch)
tree20ce025ff8234a43a343aed1d3ecac4b85232b9b /packages/Makefile
parentea0041a3b2bb4434e9b27a39e722f2b396f40426 (diff)
updated section in README on installing externals
svn path=/trunk/; revision=11035
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 218de2af..2dc9b34c 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -348,40 +348,43 @@ ifeq ($(OS_NAME),darwin)
echo "If you want to use PDP on Mac OS X 10.4/Tiger or 10.3/Panther, you will need to install X11 (X11 comes installed with 10.5/Leopard). It comes on the install CD/DVD that your computer came with. For more detail, see <a href=\"http://www.simplehelp.net/2006/10/22/how-to-install-x11-in-os-x/\" target=\"_blank\">How to install X11 in OS X</a> or <a href=\"http://puredata.info/docs/faq/macosx\" target=\"_blank\">How do I install Pd on MacOS X?</a>." >> $(README_FILE)
endif
ifeq ($(OS_NAME),windows)
- echo "<p>To install, run the installer.</p>" >> $(README_FILE)
echo "<p>To make sure that all of the included libraries are loaded when Pd runs, " >> $(README_FILE)
echo "double-click <code>C:\Program Files\pd\pd-settings.reg</code> to import the settings to the registry. WARNING: this will overwrite any existing Pd preferences!</p>" >> $(README_FILE)
endif
- echo "<h3>License</h3>" >> $(README_FILE)
- echo "<p>" >> $(README_FILE)
- echo 'This package is released under the <a href="http://www.gnu.org/copyleft/gpl.html" target="gpl">GNU GPL</a>. The Pd core and some other included code is originally available with a <a href="http://pure-data.cvs.sourceforge.net/pure-data/pd/LICENSE.txt">BSD license</a> from the Pd CVS on SourceForge.' >> $(README_FILE)
- echo "</p>" >> $(README_FILE)
echo "<h3>Installing Externals, Objects, and Help files</h3>" >> $(README_FILE)
echo "<p>" >> $(README_FILE)
- echo "If you would like to install other externals, objects, help files, etc. there are special folders that Pd-extended uses." >> $(README_FILE)
+ echo "If you would like to install other externals, objects, help files, etc. there are special folders that Pd-extended uses, which are listed below. If the folder does not exist, you should create it. You can find out more details about this by reading that FAQ: <a href=\"http://puredata.info/docs/faq/how-do-i-install-externals-and-help-files-with-pd-extended\" target=\"_blank\">How do I install externals and help files?</a>." >> $(README_FILE)
echo "<dl>" >> $(README_FILE)
- echo "<dt>User-specific</dt>" >> $(README_FILE)
ifeq ($(OS_NAME),darwin)
+ echo "<dt>Only for the current user account</dt>" >> $(README_FILE)
echo "<dd>~/Library/Pd</dd>" >> $(README_FILE)
+ echo "<dt>For all user accounts on the computer</dt>" >> $(README_FILE)
+ echo "<dd>/Library/Pd</dd>" >> $(README_FILE)
endif
ifeq ($(OS_NAME),linux)
- echo "<dd>~/pd/</dd>" >> $(README_FILE)
+ echo "<dt>Only for the current user account</dt>" >> $(README_FILE)
+ echo "<dd>~/pd-externals/</dd>" >> $(README_FILE)
+ echo "<dt>For all user accounts on the computer</dt>" >> $(README_FILE)
+ echo "<dd>/usr/share/pd-externals</dd>" >> $(README_FILE)
endif
ifeq ($(OS_NAME),windows)
- echo "<dd>%UserProfile%\Application Data\Pd</dd>" >> $(README_FILE)
+ echo "<dt>Only for the current user account</dt>" >> $(README_FILE)
+ echo "<dd><a href=\"file:///%UserProfile%/Application%20Data\">%UserProfile%\Application Data\Pd</a></dd>" >> $(README_FILE)
+ echo "<dt>For all user accounts on the computer</dt>" >> $(README_FILE)
+ echo "<dd><a href=\"file:///%ProgramFiles%/Common%20Files/\">%ProgramFiles%\Common Files\Pd</a></dd>" >> $(README_FILE)
endif
- echo "<dt>Global</dt>" >> $(README_FILE)
ifeq ($(OS_NAME),darwin)
- echo "<dd>/Library/Pd</dd>" >> $(README_FILE)
endif
ifeq ($(OS_NAME),linux)
- echo "<dd>/usr/share/pd</dd>" >> $(README_FILE)
endif
ifeq ($(OS_NAME),windows)
- echo "<dd>%ProgramFiles%\Common Files\Pd</dd>" >> $(README_FILE)
endif
echo "</dl>" >> $(README_FILE)
echo "</p>" >> $(README_FILE)
+ echo "<h3>License</h3>" >> $(README_FILE)
+ echo "<p>" >> $(README_FILE)
+ echo 'This package is released under the <a href="http://www.gnu.org/copyleft/gpl.html" target="gpl">GNU GPL</a>. The Pd core and some other included code is originally available with a <a href="http://pure-data.cvs.sourceforge.net/pure-data/pd/LICENSE.txt">BSD license</a> from the Pd CVS on SourceForge.' >> $(README_FILE)
+ echo "</p>" >> $(README_FILE)
echo "<h3>Patented Algorithms</h3>" >> $(README_FILE)
echo "<p>" >> $(README_FILE)
echo "This package may contain software that is covered by patents in certain countries, like the U.S. and Germany. In order to use this software you must have the proper license. Below is a list of the known software packages that are covered by patents in some countries:" >> $(README_FILE)