aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-08 18:09:36 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-08 18:09:36 +0000
commite66f4558b7c3fcc0b49e4f37eb1b319fdf4feb86 (patch)
tree930f54f7f5e3092dce57da2ca3644a8059970429 /packages/Makefile
parent54ef08a2b322f49912b2cf2c7965e36479d761f3 (diff)
changed gem targets to use the Gem autogen.sh script
svn path=/trunk/; revision=11716
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 08006080..040aa6e9 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -202,7 +202,7 @@ externals_install:
# gem_install
GEM_NAME = Gem
$(gem_src)/src/configure:
- make -C $(gem_src)/src configure
+ cd $(gem_src)/src && ./autogen.sh
# each platform currently needs a custom ./configure, so this is commented out
# until the ./configure defaults work on all three platforms
@@ -212,17 +212,11 @@ $(gem_src)/src/configure:
$(gem_src)/src/Gem.dll:
$(gem_src)/src/Gem.pd_linux: $(gem_src)/src/configure
-# always run aclocal/autoconf until "configure" is deleted from CVS
- cd $(gem_src)/src && aclocal
- cd $(gem_src)/src && autoconf
cd $(gem_src)/src && ./configure \
--without-ffmpeg --with-pd=$(pd_src) --disable-NV
$(MAKE) -C $(gem_src)/src
$(gem_src)/src/Gem.pd_darwin:
-# always run aclocal/autoconf until "configure" is deleted from CVS
- cd $(gem_src)/src && aclocal
- cd $(gem_src)/src && autoconf
cd $(gem_src)/src && ./configure \
--without-x --without-ImageMagick --without-v4l \
--without-tiff --without-jpeg --without-mpeg --without-mpeg3 \