aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-28 06:46:18 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-28 06:46:18 +0000
commit030d2eec4fd115d8fa54c32873095420ce30ccad (patch)
treeaaf158eb959a1e1e8f641e2e324d238d3fb04c3f /packages/darwin_app/Makefile
parent450695869e334f4626e08c53e429501d61b11e18 (diff)
- finally got a Linux Pd-extended release out, RC5
- built a tar.bz2 package maker with a generated Makefile for installing and uninstalling - switched all Makefiles to follow GNU $(DESTDIR)/$(prefix) standards svn path=/trunk/; revision=4064
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 607552c6..3039ab77 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -8,7 +8,7 @@ CWD := $(shell pwd)
BUILD_BASE = $(CWD)/build
PD_APP_NAME = $(PACKAGE_NAME)
PD_APP_CONTENTS = $(BUILD_BASE)/$(PD_APP_NAME).app/Contents
-prefix = $(PD_APP_CONTENTS)/Resources
+DESTDIR = $(PD_APP_CONTENTS)/Resources
cvs_root_dir = $(CWD)/../..
BUILDLAYOUT_DIR = $(CWD)/..
@@ -30,6 +30,7 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
cvs_root_dir=$(cvs_root_dir) \
prefix=$(prefix) \
+ DESTDIR=$(DESTDIR) \
UNAME=$(UNAME)
install: darwin_app
@@ -107,7 +108,7 @@ darwin_app_doc_format:
cd $(pddocdir) && \
sed -i.bak 's/^\(\#N canvas [0-9]* [0-9]* [0-9]* [0-9]*\) 12/\1 10/' \
*/*.pd */*/*.pd */*/*/*.pd
- find $(prefix) -name '*.pd.bak' -delete
+ find $(DESTDIR) -name '*.pd.bak' -delete
#==============================================================================#
#