aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-05 23:18:36 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-05 23:18:36 +0000
commit4118d41232b8a767d5acd273e88165050edb7ff4 (patch)
treed3c023039bd76b00c4ed82c5dc5c9dd49eed03c2 /packages/darwin_app/Makefile
parentb20a46613ffa4af3604e07689e687ba31cf5e620 (diff)
fixed up doc_format to remove .svn and removed old strip_hack; fixed Pd.app perms; added configure flags to Gem to try to get artlookit working
svn path=/trunk/; revision=11690
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 22d54a82..0c29417b 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -210,7 +210,9 @@ dmg: pdp_help_hack
# To enable the local image icon
/Developer/Tools/SetFile -a C /Volumes/$(VOLUME_NAME)/.VolumeIcon.icns \
/Volumes/$(VOLUME_NAME)
- chmod -R a-w "/Volumes/$(VOLUME_NAME)/$(PD_APP_NAME).app/Contents/Resources/doc"
+ $(MAKE) -C $(packages_src) \
+ DESTDIR="/Volumes/$(VOLUME_NAME)/$(PD_APP_NAME).app/Contents/Resources" doc_format
+ chmod -R a-w "/Volumes/$(VOLUME_NAME)/$(PD_APP_NAME).app/Contents/Resources"
hdiutil detach `mount | grep $(VOLUME_NAME) | cut -d ' ' -f 1`
hdiutil convert -format UDZO -o "$(PACKAGE_NAME).dmg" build.dmg
rm -f build.dmg