aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-18 06:14:23 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-18 06:14:23 +0000
commit6bcb9aa9966f10273ce083cee52af1896bddfd26 (patch)
tree0a6fe4e2f8c0bc9027e07b19ef5e127468a77e26 /packages/darwin_app/Makefile
parentc37876599e8757700f5fd6137e12232d1691b7a2 (diff)
tweaked things to allow for setting CPU-specific build flags
svn path=/trunk/; revision=6937
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 6962f15e..295f87ff 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -26,34 +26,34 @@ WISH_CONTENTS = "$(WISH)/Contents"
TARGET_PLATFORM := $(shell uname -p)
# base level optimizations
-OPT_CFLAGS = -Os -funroll-loops -fomit-frame-pointer
+#OPT_CFLAGS = -Os -funroll-loops -fomit-frame-pointer
-# auto-vectorization in GCC 4.x (too buggy in 4.0, wait for 4.1)
-#OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=3
+# auto-vectorization in GCC 4.x for CPUs with SIMD
+OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=3
ifeq ($(TARGET_PLATFORM),i386)
-OPT_CFLAGS += -march=pentium3 -msse -msse2 -mfpmath=sse
+OPT_CFLAGS += -march=pentium4 -msse -msse2 -mfpmath=sse
endif
ifeq ($(TARGET_PLATFORM),powerpc)
-# Package default, support older PowerPCs, but G4 (7450) is the most common
-OPT_CFLAGS += -mcpu=powerpc -mtune=7450 -mpowerpc-gfxopt
+# Package default, support older PowerPCs, but G3 is the most common
+#OPT_CFLAGS += -mcpu=powerpc -mtune=G3
-# CPU-specific gleaned from http://developer.apple.com/releasenotes/DeveloperTools/RN-GCC4/
-# check this too: http://hpc.sourceforge.net/
+# CPU-specific gleaned from:
+# http://developer.apple.com/releasenotes/DeveloperTools/RN-GCC4/
+# http://hpc.sourceforge.net/
# Generic PowerPC
#OPT_CFLAGS += -mcpu=powerpc -mpowerpc
# PowerPC 750 (G3)
#OPT_CFLAGS += -mcpu=750 -mpowerpc-gfxopt
# PowerPC 7400 (G4 <= 700Mhz)
-#OPT_CFLAGS += -mcpu=7400 -faltivec -mpowerpc-gfxopt
+#OPT_CFLAGS += -fast -fPIC -mcpu=G4 -mtune=G4
# PowerPC 7450 (G4 >= 533MHz)
-#OPT_CFLAGS += -fPIC -mcpu=7450 -mtune=7450 -fast -faltivec -ffast-math -mpowerpc-gfxopt
-# PowerPC G5 (gcc-3.3)
-#OPT_CFLAGS += -fast -fPIC -faltivec -mpowerpc-gpopt -mpowerpc-gfxopt
+OPT_CFLAGS += -fast -fPIC -mcpu=7450 -mtune=7450
+# PowerPC G5 (gcc-4.x)
+#OPT_CFLAGS += -fast -fPIC
endif
-
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree
DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
@@ -339,6 +339,7 @@ test_package:
test_locations:
@echo --------------------------------------------------
+ @echo "OPT_CFLAGS: $(OPT_CFLAGS)"
@echo "PD_VERSION: $(PD_VERSION)"
@echo "PACKAGE_NAME: $(PACKAGE_NAME)"
@echo "PD-EXTENDED_VERSION: $(PD-EXTENDED_VERSION)"