aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
commit96e0cea2e3cf39a0ed3d92aa0b69e5acebb93c22 (patch)
tree329ac7c02c02ba0123a3c8e8cb6dd54d6bafb48f /packages/darwin_app/Makefile
parent8b0a0bfca0ba5d6fa772cc8ed92851494d15103d (diff)
streamlined global debug flags and added -fno-inline-functions for valgrind
svn path=/trunk/; revision=15771
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 634ce04b..22392ace 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -27,11 +27,12 @@ WISH_CONTENTS = "$(WISH)/Contents"
#STRIP = strip -x
STRIP = echo
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE
+
# CPU-specific gleaned from:
# http://developer.apple.com/releasenotes/DeveloperTools/RN-GCC4/
# http://hpc.sourceforge.net/
-
-OPT_CFLAGS = -fast -fPIC -ftree-vectorize -ftree-vectorizer-verbose=1 -g
+OPT_CFLAGS = -fast -fPIC -ftree-vectorize -ftree-vectorizer-verbose=1
# which CPU to compile for
TARGET_PLATFORM := $(shell uname -p)
@@ -46,7 +47,7 @@ else
OPT_CFLAGS += -mcpu=7450 -mtune=7450
endif
-OPT_FLAGS += -DDEBUG_SOUNDFILE
+OPT_CFLAGS += $(DEBUG_CFLAGS)
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree