aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-01-27 21:30:19 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-01-27 21:30:19 +0000
commita205d6e9bd1ec5237f9c08c77bcba0c32e8865e8 (patch)
tree9e8a824a225c84c6c32c029acf23ee4f28191935 /packages/darwin_app/Makefile
parentfa0d50e99a8ba62e2ce5680fa147d4e77d45e37c (diff)
embed the included languages into the Info.plist to enable per-app language selection
svn path=/trunk/; revision=15894
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index a05b7e99..92609bb3 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -130,11 +130,13 @@ endif # NOT /System
#------------------------------------------------------------------------------#
# generate Info.plist using PD_APP_NAME and PD_VERSION
Info.plist: CFBUNDLEVERSION_DATE := $(shell date +%Y.%m.%d)
+Info.plist: CFBUNDLELOCALIZATIONS := $(shell $(packages_src)/darwin_app/embed-languages-in-info-list.py $(pd_src)/po/Makefile.am)
Info.plist: Info.plist.in
cat Info.plist.in | \
sed 's/PD_APP_NAME/$(PD_APP_NAME)/' | \
sed 's/CFBUNDLESHORTVERSIONSTRING/$(PD_MAJOR_VERSION).$(PD_MINOR_VERSION).$(PD_BUGFIX_VERSION)/' | \
- sed 's/CFBUNDLEVERSION/$(CFBUNDLEVERSION_DATE)/' > \
+ sed 's/CFBUNDLEVERSION/$(CFBUNDLEVERSION_DATE)/' | \
+ sed 's|CFBUNDLELOCALIZATIONS|$(CFBUNDLELOCALIZATIONS)|' > \
Info.plist
spotlight_importer_install: