aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2008-08-18 16:43:44 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2008-08-18 16:43:44 +0000
commitb84bfc4ae52289d5a88a47400ac9d269746c6ce4 (patch)
tree4c89673ab386f54ffbcaabd83a2ca6090fe13326 /packages/darwin_app/Makefile
parenteddaa7707b71a2d633aba918336f6f25e85f6ddf (diff)
changed deprecated -mcpu flags to -march
svn path=/trunk/; revision=10253
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 568e7422..f2103209 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -31,11 +31,11 @@ TARGET_PLATFORM := $(shell uname -p)
# 10.3 uses gcc 3.3, and 10.3 only runs on PowerPC
GCC_VERSION := $(shell gcc -dumpversion)
ifeq ($(GCC_VERSION),3.3)
-OPT_CFLAGS += -O3 -funroll-loops -fomit-frame-pointer -mcpu=powerpc -mtune=G3
+OPT_CFLAGS += -O3 -funroll-loops -fomit-frame-pointer -march=powerpc -mtune=G3
else
# auto-vectorization in GCC 4.x for CPUs with SIMD
OPT_CFLAGS = -ftree-vectorize -ftree-vectorizer-verbose=2 \
- -fast -fPIC -mcpu=7450 -mtune=7450
+ -fast -fPIC -march=7450 -mtune=7450
endif
# Mac/Intels only run 10.4, so always gcc 4.x