aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-01-21 17:39:56 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-01-21 17:39:56 +0000
commitbee18d0a6631086662c1ff4d2b88f2460b5ded66 (patch)
tree330d0dc3cf18468a69e75887fd0343ea81724245 /packages/darwin_app/Makefile
parent5afd001326dc1960170d959bb8cc2fab6c28de6d (diff)
- removed flext bits since they are broken. the flext files should be
installed along with the binaries instead of here. - removed old Mac-only devel/pd++ build system that has been long abandoned svn path=/trunk/; revision=10584
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile56
1 files changed, 0 insertions, 56 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 20054011..ff61da65 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -59,7 +59,6 @@ all:
$(MAKE) -C $(packages_src) $(DEST_PATHS)
install: darwin_app
-devel_install: darwin_app_devel
#------------------------------------------------------------------------------#
darwin_app: darwin_app_core extended_install rez_install darwin_app_embed_libs spotlight_importer_install
@@ -70,11 +69,6 @@ extended_install:
$(MAKE) -C $(packages_src) $(DEST_PATHS) extended_install
#------------------------------------------------------------------------------#
-darwin_app_devel: darwin_app_devel_core rez_install spotlight_importer_install
- @echo " "
- @echo "Pd_devel.app build succeeded!"
-
-#------------------------------------------------------------------------------#
# this target is for when you already have a pre-built Pd.app and you
# just want to fill it with goodies from CVS. To do so, place your
# Pd.app in $(BUILD_BASE)/Pd.app
@@ -132,29 +126,6 @@ endif # NOT /System
"$(PD_APP_CONTENTS)/MacOS/${PD_APP_NAME}"
#------------------------------------------------------------------------------#
-#
-darwin_app_devel_wrapper: Info.plist
-# copy Wish Shell.app from default install location
-# note: use the "standalone" Wish shell to make a "standalone" pd app
- install -d "$(PD_APP_CONTENTS)/MacOS"
- install -m0755 -p \
- "$(WISH_CONTENTS)/MacOS/$(WISH_NAME)" \
- "$(PD_APP_CONTENTS)/MacOS"
- install -d "$(PD_APP_CONTENTS)/Resources"
- install -m0644 -p \
- "$(WISH_CONTENTS)/Resources/$(WISH_NAME).rsrc" \
- "$(PD_APP_CONTENTS)/Resources"
- install -d "$(PD_APP_CONTENTS)/Frameworks"
- cp -Rp "$(WISH_CONTENTS)/Frameworks" "$(PD_APP_CONTENTS)"
-# set up app wrapper
- install -d "$(PD_APP_CONTENTS)/Resources/Scripts"
- install -d "$(PD_APP_CONTENTS)/Resources/bin"
- install -m0644 -p Info.plist "$(PD_APP_CONTENTS)"
- install -m0644 -p *.icns "$(PD_APP_CONTENTS)/Resources"
- mv "$(PD_APP_CONTENTS)/MacOS/${WISH_NAME}" \
- "$(PD_APP_CONTENTS)/MacOS/${PD_APP_NAME}"
-
-#------------------------------------------------------------------------------#
# generate Info.plist using PD_APP_NAME and PD_VERSION
Info.plist: CFBUNDLEVERSION_DATE := $(shell date +%Y.%m.%d)
Info.plist: Info.plist.in
@@ -214,29 +185,6 @@ darwin_app_core: darwin_app_wrapper
# create directory to put Spotlight Importers into
-
-#------------------------------------------------------------------------------#
-darwin_app_devel_core: darwin_app_devel_wrapper
- cd $(packages_src) && \
- $(MAKE) $(DEST_PATHS) PD_CONFIGURE_FLAGS=--enable-jack devel_install
- cd "$(PD_APP_CONTENTS)/Resources/Scripts" && \
- ln -s ../bin/pd.tk AppMain.tcl
-# support for Info Panel Plugins mgmt
- cd "$(PD_APP_CONTENTS)" && ln -s Resources/extra Plugins
-# run script to move help-*.pd files to *-help.pd according to the standard
- cd $(pddocdir) && \
- $(scripts_src)/convert-help-to-standard.sh
-
-
-#==============================================================================#
-#
-## CVS SOURCES
-#
-#==============================================================================#
-
-#------------------------------------------------------------------------------#
-darwin_app_externals: darwin_app_externals_standard darwin_app_externals_flext
-
#==============================================================================#
#
## PACKAGING
@@ -303,10 +251,6 @@ package_clean: darwin_app_clean spotlight_importer_clean
spotlight_importer_clean:
-rm -rf -- spotlight_importer/build
-devel_clean: darwin_app_devel_clean
- $(MAKE) -C $(packages_src) $(DEST_PATHS) clean
- -rm Info.plist
-
darwin_app_clean:
-chmod -R u+w $(PD_APP_CONTENTS)/Frameworks
-rm -rf -- $(PD_APP_CONTENTS)/Frameworks