aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-08 05:29:38 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-08 05:29:38 +0000
commitc038237c1e8fe5b36243c11914f393fecd6b3b91 (patch)
treeb8d35613ec19ac5f0d7f388a2b0c28dbdc36c65e /packages/darwin_app/Makefile
parent93534f61b89740c88d00dbd2b8a3e1ad2e7daed8 (diff)
since the Universal/Fat flags and OPT_CFLAGS can clash, specify them both here so they can managed globally
svn path=/trunk/; revision=11710
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 0c29417b..8bc61e83 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -27,13 +27,14 @@ WISH_CONTENTS = "$(WISH)/Contents"
# http://hpc.sourceforge.net/
OPT_CFLAGS = -fast -fPIC -ftree-vectorize -ftree-vectorizer-verbose=2
+FAT_FLAGS = -mmacosx-version-min=10.4
# which CPU to compile for
TARGET_PLATFORM := $(shell uname -p)
ifeq ($(TARGET_PLATFORM),i386)
OPT_CFLAGS += -march=pentium4 -msse3 -mfpmath=sse
else
- OPT_CFLAGS += -mcpu=7400 -mtune=7400
+ OPT_CFLAGS += -mcpu=7450 -mtune=7450
endif
OPT_FLAGS += -DDEBUG_SOUNDFILE
@@ -45,6 +46,7 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
prefix=$(prefix) \
DESTDIR=$(DESTDIR) \
OPT_CFLAGS="$(OPT_CFLAGS)" \
+ FAT_FLAGS="$(FAT_FLAGS)" \
UNAME=$(UNAME)
all: