aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-10-20 23:57:46 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-10-20 23:57:46 +0000
commit172adb321325cb9980409470f0b50d81ac947687 (patch)
treefaf71ae127d660cd06338d5717d7900332cd563b /packages/darwin_app
parent67577806ae3a2575148e404e5df27ed29979e044 (diff)
moved dmg code from branch-v0-39-2-extended, the disk image icon works, but not the background...
svn path=/trunk/; revision=8853
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 3e6ad419..ab1b99e7 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -258,14 +258,20 @@ dmg:
-hdiutil detach "/Volumes/$(VOLUME_NAME)"
hdiutil attach build.dmg
install -p $(manualsdir)/Pd/ReadMe.html "/Volumes/$(VOLUME_NAME)"
- install -d "/Volumes/$(VOLUME_NAME)/.imagefolder"
# add link to /Applications for easy install
ln -s /Applications /Volumes/$(VOLUME_NAME)/Applications
-# background image will only show when the disk image is called "$(VOLUME_NAME)
-# the background image needs to be added to the .DS_Store to work
- install -p background.png "/Volumes/$(VOLUME_NAME)/.imagefolder/"
+# Install to .background for easier manual DS_Store makeing
+ install -d "/Volumes/$(VOLUME_NAME)/.background"
+# The full path to the background image needs to be added to .DS_Store to work
+# Hence the background image will only show when the disk image is called
+# "$(VOLUME_NAME)=Pd-extended - that is what the current DS_Store uses.
+# To create the DS_Store file one must... search the net.
+ install -p background.png "/Volumes/$(VOLUME_NAME)/.background/"
install -p DS_Store "/Volumes/$(VOLUME_NAME)/.DS_Store"
install -p VolumeIcon.icns "/Volumes/$(VOLUME_NAME)/.VolumeIcon.icns"
+# To enable the local image icon
+ /Developer/Tools/SetFile -a C /Volumes/$(VOLUME_NAME)/.VolumeIcon.icns \
+ /Volumes/$(VOLUME_NAME)
chmod -R a-w "/Volumes/$(VOLUME_NAME)/$(PD_APP_NAME).app/Contents/Resources/doc"
hdiutil detach `mount | grep $(VOLUME_NAME) | cut -d ' ' -f 1`
hdiutil convert -format UDZO -o "$(PACKAGE_NAME).dmg" build.dmg