aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-22 06:13:22 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-22 06:13:22 +0000
commit1eabfbfa0df32e2f2d6b2f8e71fb516ccc812672 (patch)
tree5706a6a84d724885d380015baa89934d66ef9694 /packages/darwin_app
parent2d783191e90ab424e505199deefbef2a91f52bd1 (diff)
updated to use Wish.app for TclTk 8.4.10
svn path=/trunk/; revision=4607
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index c06309c4..f2440674 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -21,7 +21,10 @@ BUILDLAYOUT_DIR = $(CWD)/..
# and mount it. The files will be copied from the mounted .dmg image.
#WISH = /Applications/Utilities/Wish\ Shell.app
TCLTK := $(shell /bin/ls -1r TclTkAquaStandalone-8.?.*.dmg|head -1|sed 's/\.dmg//')
-WISH_NAME = Wish\ Shell
+# Tcl/Tk < 8.4.10
+#WISH_NAME = Wish\ Shell
+# Tcl/Tk >= 8.4.10
+WISH_NAME = Wish
WISH = /Volumes/$(TCLTK)/$(WISH_NAME).app
WISH_CONTENTS = $(WISH)/Contents
@@ -103,7 +106,7 @@ darwin_app_wrapper: Info.plist
install -d "$(PD_APP_CONTENTS)/Resources/Scripts"
install -m0644 -p Info.plist "$(PD_APP_CONTENTS)"
install -m0644 -p *.icns "$(PD_APP_CONTENTS)/Resources"
- mv "$(PD_APP_CONTENTS)/MacOS/Wish Shell" \
+ mv "$(PD_APP_CONTENTS)/MacOS/${WISH_NAME}" \
"$(PD_APP_CONTENTS)/MacOS/Pd"
# diskutil eject /Volumes/$(TCLTK)