aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-25 20:21:11 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-25 20:21:11 +0000
commit9a1143111aabeedc13ec27b28cc81426f4dbf147 (patch)
tree96e803268203aedc833f0d6c6abfdd3340aba0ca /packages/darwin_app
parent46f8a3c341a2481c0ab16873959e15d6676dc9d4 (diff)
add -f to ln to force creation of links so that install targets can install over existing builds (Closes #3413815 from Jacob Lee)
svn path=/trunk/; revision=15344
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index bfdc41c1..927718ae 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -162,15 +162,15 @@ darwin_app_core: darwin_app_wrapper
pd_install
install -d "$(PD_APP_CONTENTS)/Resources/bin"
cd "$(PD_APP_CONTENTS)/Resources" && \
- ln -s tcl Scripts
+ ln -s -f tcl Scripts
cd "$(PD_APP_CONTENTS)/Resources/bin" && \
test -e pdextended || ln -s pd pdextended
# support for Info Panel Plugins mgmt
- cd "$(PD_APP_CONTENTS)" && ln -s Resources/extra Plugins
+ cd "$(PD_APP_CONTENTS)" && ln -s -f Resources/extra Plugins
install -p -m0644 org.puredata.pdextended.default.plist "$(PD_APP_CONTENTS)/"
# since Pd-vanilla on Mac OS X doesn't have an 'include/pd' folder,
# Pd-extended will mimic Pd-vanilla's include/pd until Pd-vanilla gets one
- ln -s pdextended "$(PD_APP_CONTENTS)/Resources/include/pd"
+ ln -s -f pdextended "$(PD_APP_CONTENTS)/Resources/include/pd"
#==============================================================================#
@@ -190,7 +190,7 @@ dmg:
hdiutil attach build.dmg
install -p $(DESTDIR)$(manualsdir)/Pd/ReadMe.html "/Volumes/$(VOLUME_NAME)"
# add link to /Applications for easy install
- ln -s /Applications /Volumes/$(VOLUME_NAME)/Applications
+ ln -s -f /Applications /Volumes/$(VOLUME_NAME)/Applications
# Install to .background for easier manual DS_Store makeing
install -d "/Volumes/$(VOLUME_NAME)/.background"
# The full path to the background image needs to be added to .DS_Store to work