aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-13 03:55:08 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-13 03:55:08 +0000
commitacd37d4a37c223094f3e91803fe0fdcb01f17eee (patch)
tree1a6e576bd17dcc85d7f9edf53289b0604f0b6257 /packages/darwin_app
parent3c509cab622d1a4afbafec461c7e61484f6219dd (diff)
This should be the final Pd-0.38.4-extendedRC8 build, which should be the
release of Pd-0.38.4-extended. A couple of minor changes: - added liblist to the config files since [list] was backported to 0.38.4 in the form of liblist - removed the MACOSX -> __APPLE__ regexp stuff since it was just for testing until Miller accepted those changes. - tried to make the org.puredata.pd.plist file get installed with write permissions so that people can overwrite and change the default file after they install it. svn path=/trunk/; revision=4584
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile7
-rw-r--r--packages/darwin_app/TODO8
-rw-r--r--packages/darwin_app/org.puredata.pd.plist48
3 files changed, 36 insertions, 27 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 71b08cb8..c06309c4 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -140,15 +140,16 @@ darwin_app_core: darwin_app_wrapper
-darwin_app_doc_format:
# set the font to 10pt on all help patches
# the BSD/Darwin version of sed must create a backup file when doing
# in-place replacement, so delete the unneeded backup files
+darwin_app_doc_format:
cd $(pddocdir) && \
sed -i.bak 's/^\(\#N canvas [0-9]* [0-9]* [0-9]* [0-9]*\) 12/\1 10/' \
*/*.pd */*/*.pd */*/*/*.pd
find $(DESTDIR) -name '*.pd.bak' -delete
+
#==============================================================================#
#
## CVS SOURCES
@@ -182,13 +183,13 @@ package: dmg
DMG_NAME = $(PACKAGE_NAME)
dmg: darwin_app_perms
install -d "$(CWD)/$(DMG_NAME)"
- install -p -m0444 $(manualsdir)/Pd/Pd-LICENSE.txt \
+ install -p -m0644 $(manualsdir)/Pd/Pd-LICENSE.txt \
$(manualsdir)/Pd/License.html \
$(manualsdir)/Pd/Welcome.html \
$(manualsdir)/Pd/ReadMe.html \
"$(CWD)/$(DMG_NAME)"
cd $(BUILD_BASE) && mv $(PD_APP_NAME).app "$(CWD)/$(DMG_NAME)/"
- install -p -m0444 org.puredata.pd.plist "$(CWD)/$(DMG_NAME)"
+ install -p -m0644 org.puredata.pd.plist "$(CWD)/$(DMG_NAME)"
cd $(CWD) && /bin/sh mkdmg "$(DMG_NAME)"
diff --git a/packages/darwin_app/TODO b/packages/darwin_app/TODO
index 3eb7a818..de1ff67a 100644
--- a/packages/darwin_app/TODO
+++ b/packages/darwin_app/TODO
@@ -1,9 +1,8 @@
-- OSC did not get included
+- check code to make it all use single-precision/libmx functions on Mac OSX.
-- check out embed-MacOSX-dependencies.sh script. There seems to be a bug
- where the deps in lib/libogg.dylib don't get switched from /sw/lib to
- @executable_path/blah/blah
+
+- make sure that org.puredata.pd.plist is rw in the .dmg (possible?)
- check out using TclTkBI package for all of the tcl deps. It should have all
@@ -33,6 +32,7 @@ http://developer.apple.com/documentation/MacOSX/Conceptual/BPFileSystem/Articles
- create Tcl script called from Prefs that creates links for the standard unix
+ (this probably makes more sense to have in "make devsymlinks")
- redo menu system
diff --git a/packages/darwin_app/org.puredata.pd.plist b/packages/darwin_app/org.puredata.pd.plist
index 023ca976..6c11cf57 100644
--- a/packages/darwin_app/org.puredata.pd.plist
+++ b/packages/darwin_app/org.puredata.pd.plist
@@ -13,46 +13,54 @@
<key>loadlib5</key>
<string>ext13</string>
<key>loadlib6</key>
- <string>iemabs</string>
+ <string>fftease</string>
<key>loadlib7</key>
- <string>iemmatrix</string>
+ <string>hid</string>
<key>loadlib8</key>
- <string>markex</string>
+ <string>iemabs</string>
<key>loadlib9</key>
- <string>maxlib</string>
+ <string>iemmatrix</string>
<key>loadlib10</key>
- <string>memento</string>
+ <string>liblist</string>
<key>loadlib11</key>
- <string>mjlib</string>
+ <string>markex</string>
<key>loadlib12</key>
- <string>motex</string>
+ <string>maxlib</string>
<key>loadlib13</key>
- <string>oscx</string>
+ <string>memento</string>
<key>loadlib14</key>
- <string>pddp</string>
+ <string>mjlib</string>
<key>loadlib15</key>
- <string>pdogg</string>
+ <string>motex</string>
<key>loadlib16</key>
- <string>pdp</string>
+ <string>oscx</string>
<key>loadlib17</key>
- <string>pidip</string>
+ <string>pddp</string>
<key>loadlib18</key>
- <string>pixeltango</string>
+ <string>pdogg</string>
<key>loadlib19</key>
- <string>pmpd</string>
+ <string>pdp</string>
<key>loadlib20</key>
- <string>rradical</string>
+ <string>pidip</string>
<key>loadlib21</key>
- <string>sigpack</string>
+ <string>pixeltango</string>
<key>loadlib22</key>
- <string>smlib</string>
+ <string>pmpd</string>
<key>loadlib23</key>
- <string>toxy</string>
+ <string>rradical</string>
<key>loadlib24</key>
- <string>unauthorized</string>
+ <string>sigpack</string>
<key>loadlib25</key>
- <string>vbap</string>
+ <string>smlib</string>
<key>loadlib26</key>
+ <string>toxy</string>
+ <key>loadlib27</key>
+ <string>unauthorized</string>
+ <key>loadlib28</key>
+ <string>vasp</string>
+ <key>loadlib29</key>
+ <string>vbap</string>
+ <key>loadlib30</key>
<string>xsample</string>
</dict>
</plist>