aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-21 23:02:55 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-21 23:02:55 +0000
commitaf956011f7d4548ed67ae5633348040df877c6e7 (patch)
treec2faf5a68037c7abd512a5290b7ac79398cbcf0b /packages/darwin_app
parentc63477f28fb58e3c14ff16a8173f431a281053fc (diff)
created Pd-0.38.4-extendedRC3.app release
svn path=/trunk/; revision=4012
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile31
-rw-r--r--packages/darwin_app/TODO2
-rw-r--r--packages/darwin_app/org.puredata.pd.plist8
3 files changed, 28 insertions, 13 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 84110594..4efaa701 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -38,7 +38,9 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
install: darwin_app
#------------------------------------------------------------------------------#
-darwin_app: darwin_app_core extended_app_install
+darwin_app: darwin_app_core extended_app_install rez
+ @echo " "
+ @echo "Pd.app build succeeded!"
#------------------------------------------------------------------------------#
# this target is for when you already have a pre-built Pd.app and you
@@ -68,34 +70,36 @@ darwin_app_wrapper:
install -d "$(PD_APP_CONTENTS)/Resources/Scripts"
install -m0644 -p Info.plist "$(PD_APP_CONTENTS)"
install -m0644 -p *.icns "$(PD_APP_CONTENTS)/Resources"
-# rename the Wish Shell executable to "pd", the all lowercase is important
-# since it needs to match the pd executable in order for the Gem windows to
-# get focus properly
mv "$(PD_APP_CONTENTS)/MacOS/Wish Shell" \
- "$(PD_APP_CONTENTS)/MacOS/pd"
+ "$(PD_APP_CONTENTS)/MacOS/$(PD_APP_NAME)"
# diskutil eject /Volumes/$(TCLTK)
+#------------------------------------------------------------------------------#
+# generate Info.plist using PD_APP_NAME and PD_VERSION
+Info.plist: Info.plist.in
+
+
+# tigital's Gem window focus black magic
+rez:
+ install -p $(CWD)/mac.r $(BIN_DEST)
+ cd $(BIN_DEST) && /Developer/tools/Rez -t APPL mac.r -o pd
+
#------------------------------------------------------------------------------#
darwin_app_core: darwin_app_wrapper
cd $(PACKAGES_SRC) && \
make $(DEST_PATHS) PD_CONFIGURE_FLAGS=--enable-jack pd_install
-# tigital's Gem window focus black magic:
- install -p $(CWD)/mac.r $(BIN_DEST)
- cd $(BIN_DEST) && /Developer/tools/Rez -t APPL mac.r -o pd
cd "$(PD_APP_CONTENTS)/Resources/Scripts" && \
ln -s ../bin/pd.tk AppMain.tcl
# support for Info Panel Plugins mgmt
cd "$(PD_APP_CONTENTS)" && ln -s Resources/extra Plugins
-# Headers
- install -d $(INSTALL_PREFIX)/include
- install $(PD_SRC)/src/*.h $(INSTALL_PREFIX)/include
# run script to move help-*.pd files to *-help.pd according to the standard
cd $(DOCS_DEST) && \
$(SCRIPTS_SRC)/convert-help-to-standard.sh
+
darwin_app_doc_format:
# set the font to 10pt on all help patches
# the BSD/Darwin version of sed must create a backup file when doing
@@ -288,8 +292,9 @@ darwin_app_perms:
dmg: darwin_app_perms
install -d "$(CWD)/$(DMG_NAME)"
cd $(BUILD_BASE) && mv $(PD_APP_NAME).app "$(CWD)/$(DMG_NAME)/$(DMG_NAME).app"
- install -p -m0444 $(INSTALL_PREFIX)/*.txt $(INSTALL_PREFIX)/*.html \
- "$(CWD)/$(DMG_NAME)"
+# install -p -m0444 $(MANUALS_DEST)/$(PD_NAME)/PD\ LICENSE.txt \
+# $(MANUALS_DEST)/*.html "$(CWD)/$(DMG_NAME)"
+ install -p -m0444 org.puredata.pd.plist "$(CWD)/$(DMG_NAME)"
cd $(CWD) && /bin/sh mkdmg "$(DMG_NAME)"
diff --git a/packages/darwin_app/TODO b/packages/darwin_app/TODO
index 108c0481..9471abaa 100644
--- a/packages/darwin_app/TODO
+++ b/packages/darwin_app/TODO
@@ -1,4 +1,6 @@
+- make Info.plist.in template and have the Makefile create Info.plist
+
- check to make sure that Rez mac.r is working in Makefile
- make Pd open a new window when its launched to workaround the bug where the
diff --git a/packages/darwin_app/org.puredata.pd.plist b/packages/darwin_app/org.puredata.pd.plist
index ed25e182..0f3370c1 100644
--- a/packages/darwin_app/org.puredata.pd.plist
+++ b/packages/darwin_app/org.puredata.pd.plist
@@ -12,6 +12,14 @@
<string>dyn~</string>
<key>loadlib5</key>
<string>pmpd</string>
+ <key>loadlib6</key>
+ <string>cyclone</string>
+ <key>loadlib7</key>
+ <string>memento</string>
+ <key>loadlib8</key>
+ <string>toxy</string>
+ <key>loadlib9</key>
+ <string></string>
<key>standardpath</key>
<string>1</string>
</dict>